Apps not starting- going right back to home screen

Gr80Likes2Boogi

macrumors regular
Original poster
Oct 3, 2009
163
0
NoHo, CA
Hi all,

I had a jailbroken phone for a while, and its response and stability were not to my satisfaction, so I went and restored the software. I'm now running 3.1.2, and all the "Stock" apps are fine (camera, photos, voice recorder, etc), but when I go to anything I've downloaded, it pops the start screen of any app, then immediately dumps me right back to that home page. I've restarted several times, to no avail. I've perused the forums and not really found exactly what to do. Should I restore again?

Thoughts? Thanks!!
 

Moi un Mouton

macrumors 68000
Mar 18, 2008
1,686
1
Bracknell UK
It's a common problem.

First try downloading another free app to the phone, see if that fixes it. It sometimes does.

If not, delete all the apps in iTunes and sync, decline the offer to transfer the apps from the phone to iTunes. Download an app and see if it now works. If it does, download the others again.

If that doesn't work, then there are lots more threads here with other suggested solutions: LINK
 

Gr80Likes2Boogi

macrumors regular
Original poster
Oct 3, 2009
163
0
NoHo, CA
I scoured that link (thank you, btw) and restored again, deleted the apps off my phone then synced them again, downloaded a free app from the app store... no luck!!

The apps don't last more than 1 second. They will literally pop on then pop off again. Gah!! Any other ideas, friends?
 

chili

macrumors member
Oct 16, 2009
35
0
that happened to me once, i just restored AGAIN and it worked.

actually i cant remember wether i updates it or restored it...
 

Hellscream2005

macrumors newbie
Mar 14, 2009
10
0
Restoring worked for me

I had the same problem yesterday. For some weird reason after turning off phone, so that it frees some ram and works speedy again, it got stuck in the apple screen. Did a reset and it started fine, but non apple apps wouldn't open. Theres the scatter animation of icons then back to the home screen. I did a reset of the new, set as new, sync contacts, calendar, apps, jailbroke with Blackra1n, and voilá. iPhone works again, and faster cause of the fresh install. I wonder what kind of problem occured before to make it work like that. Maybe a permissions problem? I dunno...
 

Gr80Likes2Boogi

macrumors regular
Original poster
Oct 3, 2009
163
0
NoHo, CA
I did the un-authorize re-authorize deal too.

I'll try some more stuff. Mebbe restore again (three times a charm, right?)

I'll keep you updated. Thank you all!
 

Gr80Likes2Boogi

macrumors regular
Original poster
Oct 3, 2009
163
0
NoHo, CA
boomKAH!

So what you have to do is delete the app off your hdd, I previously only deleted them off the iPhone itself. Then re-download, and then sync. No, no charge for apps you've already bought (which I was scared of)

Huzzah! Thank you macforumers.
 

Similar threads

  • dmylrea
0
Replies
0
Views
64
  • mandra12
10
Replies
10
Views
517
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.