Apps not starting- going right back to home screen

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Gr80Likes2Boogi, Nov 25, 2009.

  1. Gr80Likes2Boogi macrumors regular

    Joined:
    Oct 3, 2009
    Location:
    NoHo, CA
    #1
    Hi all,

    I had a jailbroken phone for a while, and its response and stability were not to my satisfaction, so I went and restored the software. I'm now running 3.1.2, and all the "Stock" apps are fine (camera, photos, voice recorder, etc), but when I go to anything I've downloaded, it pops the start screen of any app, then immediately dumps me right back to that home page. I've restarted several times, to no avail. I've perused the forums and not really found exactly what to do. Should I restore again?

    Thoughts? Thanks!!
     
  2. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #2
    It's a common problem.

    First try downloading another free app to the phone, see if that fixes it. It sometimes does.

    If not, delete all the apps in iTunes and sync, decline the offer to transfer the apps from the phone to iTunes. Download an app and see if it now works. If it does, download the others again.

    If that doesn't work, then there are lots more threads here with other suggested solutions: LINK
     
  3. Gr80Likes2Boogi thread starter macrumors regular

    Joined:
    Oct 3, 2009
    Location:
    NoHo, CA
    #3
    I scoured that link (thank you, btw) and restored again, deleted the apps off my phone then synced them again, downloaded a free app from the app store... no luck!!

    The apps don't last more than 1 second. They will literally pop on then pop off again. Gah!! Any other ideas, friends?
     
  4. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #4
  5. chili macrumors member

    Joined:
    Oct 16, 2009
    #5
    that happened to me once, i just restored AGAIN and it worked.

    actually i cant remember wether i updates it or restored it...
     
  6. Hellscream2005 macrumors newbie

    Joined:
    Mar 14, 2009
    #6
    Restoring worked for me

    I had the same problem yesterday. For some weird reason after turning off phone, so that it frees some ram and works speedy again, it got stuck in the apple screen. Did a reset and it started fine, but non apple apps wouldn't open. Theres the scatter animation of icons then back to the home screen. I did a reset of the new, set as new, sync contacts, calendar, apps, jailbroke with Blackra1n, and voilá. iPhone works again, and faster cause of the fresh install. I wonder what kind of problem occured before to make it work like that. Maybe a permissions problem? I dunno...
     
  7. Gr80Likes2Boogi thread starter macrumors regular

    Joined:
    Oct 3, 2009
    Location:
    NoHo, CA
    #7
    I did the un-authorize re-authorize deal too.

    I'll try some more stuff. Mebbe restore again (three times a charm, right?)

    I'll keep you updated. Thank you all!
     
  8. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #8
    Do a restore in DFU mode and setup as new. That has to work, I would think.
     
  9. Gr80Likes2Boogi thread starter macrumors regular

    Joined:
    Oct 3, 2009
    Location:
    NoHo, CA
    #9
    boomKAH!

    So what you have to do is delete the app off your hdd, I previously only deleted them off the iPhone itself. Then re-download, and then sync. No, no charge for apps you've already bought (which I was scared of)

    Huzzah! Thank you macforumers.
     

Share This Page