Apps not syncing properly after moving iTunes library to external hard drive

Discussion in 'iPhone Tips, Help and Troubleshooting' started by red9, Jun 13, 2010.

  1. red9 macrumors member

    Joined:
    Jul 4, 2008
    #1
    I recently bought an SSD and in an effort to save space on it, moved my iTunes library (music + mobile applications folders, etc) to an external hard drive and in iTunes pointed it to that location.

    The music seems to work fine, however the issue is with iPhone apps.

    From what I can tell, it can detect apps that need updating, however when I download the updates, it'll send the .ipa files from the /external hard drive/music/itunes/mobile applications folder to the trash, however it downloads the updates to my /ssd/music/itunes/mobile applications folder.

    What I had been doing was moving those from the SSD to the external hard drive's mobile applications folder, however it looks like those app updates are not syncing properly. It seems to be hit or miss in terms of whether the updates actually get on the phone, although I am not 100% sure--I could have just forgotten and synced with the apps still in the ssd's mobile applications folder.

    So I guess the bottom line is, what's the deal with regards to getting my iPhone apps working and syncing properly when I have my itunes library on an external drive? How do I go about fixing the problem that now I have the updated apps in my mobile applications folder on my external drive, but they aren't installed on the phone? I tried dragging them to the ssd's mobile applications folder, however they still wont sync.

    Any and all help would be very greatly appreciated, thanks!
     
  2. luckyeddie macrumors newbie

    Joined:
    Jun 27, 2010
    #2
    I have the same issue. I moved my library to an external and my apps won't move. Through my efforts I now have duplicates on some apps, even triplicates on a few others.

    I don't consider myself a genius, but adept, on OS X.

    This morning I thought I would give it another go. I deleted all my apps from iTunes and the app files in my users/music/itunes (Just to make sure they were gone). Emptied the trash. (I took screen shots of my entire list of apps before I deleted anything. Unfortunately, after the duplicates/triplicates.)

    In iTunes preferences, I verified that the library for iTunes was External/itunes. I hit the reset button under the change button. The library path went back to users/music/itunes. I clicked the change button and put the path where I want it to go: external/itunes.

    I downloaded an app from the iTunes store. Checked the location, and a new folder appeared, surprise!, users/music/itunes/mobile applications. I just deleted that folder and it's back.

    Music adds just fine and where it needs to go.

    Not sure this helps, but I'm using a G4 power mac MDD, 867 MHz Dual processor, 2 G DDR RAM, running 10.5. Installed a 2.0 USB card, which my 'i' products work perfectly off of, even charges my iPad. The external is a WD 1TB about a month old now.

    Any help would be awesome!
     

Share This Page