Apps not working

Discussion in 'iPod touch' started by Poofster, Feb 14, 2012.

  1. Poofster macrumors member

    Joined:
    Oct 22, 2011
    #1
    I have an ipod touch 2nd generation..jailbroken...and my kids have ipod touch 4th generations ..not jailbroken...my problem is that any of the games i download such as temple run (free) or jetpack joyride or draw something free..all download fine but crash as soon as i open them..It seems that any of the newer games aren't working for me. Is it cause i'm jailbroken or 2nd generation or just something wrong with my ipod? They work fine on my kids ipods....ANY HELP would be APPRECIATED
     
  2. ninjaw95 macrumors 6502

    Joined:
    Nov 30, 2011
    #2
    when getting the app look at the compatibility usually above the pictures.
     
  3. Poofster thread starter macrumors member

    Joined:
    Oct 22, 2011
    #3
    Thanks, i did that with temple run and meet the requirements...I'm ios 4.2.1 and for some reason i have to reboot to play most games now that i already have...or boot into safe mode to play them...in safe mode sometimes they still crash.
     
  4. APlotdevice macrumors 68040

    APlotdevice

    Joined:
    Sep 3, 2011
    #4
    Some newer apps do have problems running on older devices. Even if it appears to meet the minimum requirements. Jailbreaking can also cause some apps to crash.
     
  5. iphone1105 macrumors 68020

    iphone1105

    Joined:
    Oct 8, 2009
    #5
    sign in and out, and in again off the app store on the device with the apps crashing on launch, should cure the issue
     
  6. Poofster thread starter macrumors member

    Joined:
    Oct 22, 2011
    #6
    Thanks, tried signing in and out and in again and Temple run still crashes.. even tried it in safe mode with the same results
     

Share This Page