iPhone Apps Opening and Then Closing

Discussion in 'Jailbreaks and iOS Hacks' started by crizza0309, Feb 27, 2014.

  1. crizza0309 macrumors regular

    Joined:
    Sep 4, 2008
    #1
    Anyone know a fix for this? its really annoying. it just started doing this and I havent downloaded anything new. I really dont wanna restore my phone :(
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    Have you tried a hard reboot ?

    Is your phone loaded up/full up to capacity ?
     
  3. crizza0309 thread starter macrumors regular

    Joined:
    Sep 4, 2008
    #3
    if by holding the lock and home button down until the boot logo comes up is a hard reboot, then yes.

    ----------

    its only with like 6 apps not every app does it.
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    If those are stock apps, you will likely have to restore, set up as new, do not restore to backup.

    If they are iTunes apps, you can try deleting them all, reboot, then re-install them then reboot again and re-test them.
     
  5. crizza0309, Feb 27, 2014
    Last edited: Feb 27, 2014

    crizza0309 thread starter macrumors regular

    Joined:
    Sep 4, 2008
    #5
    its itunes apps and i tried to reinstall the apps and that didnt work. Some of them are just weird:

    Ebay-App freezes at white splash screen
    Vine- Opens but once i click anything in the app. the app closes

    then i have 5 apps or so that open and then close right away.

    All itunes apps. Some itunes apps work fine tho
     
  6. XboxMySocks macrumors 68020

    XboxMySocks

    Joined:
    Oct 25, 2009
  7. crizza0309 thread starter macrumors regular

    Joined:
    Sep 4, 2008
    #7
    yes
     
  8. XboxMySocks macrumors 68020

    XboxMySocks

    Joined:
    Oct 25, 2009
    #8
    There you go. LOTS of applications updated recently with a new font-loading system which ***** the bed completely when you have custom fonts installed. Sucks.
     
  9. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #9
    Good to know, guess I am lucky, I have BytaFont2 running with no issues (or is this just an issue with the original BytaFont?)
     
  10. XboxMySocks macrumors 68020

    XboxMySocks

    Joined:
    Oct 25, 2009
    #10
    No, sorry, it is with BytaFont 2 and only certain fonts it seems.

    I'm currently on Helvetica Neue Light and it is working fine. A previous version of the exact same font was not.
     
  11. white4s macrumors 65816

    Joined:
    Nov 15, 2011
    Location:
    New Jersey
    #11
    same here, no issues with bytafont2 & apps
     
  12. crizza0309 thread starter macrumors regular

    Joined:
    Sep 4, 2008
    #12
    i deleted bytafont 2 and its still happening.
     
  13. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #13
    Yea, I remember when the BytaFont fonts were all updated.
     
  14. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #14
    Don't uninstall bytafont 2. Install it back and change back to the "backup" font, which is the default one

    Bytafont doesn't use mobile substrate to replace your font
     
  15. crizza0309 thread starter macrumors regular

    Joined:
    Sep 4, 2008
    #15


    this didnt work :(
     
  16. iALLOUT4eva macrumors regular

    iALLOUT4eva

    Joined:
    Oct 3, 2012
    Location:
    PlayDay Land
    #16
    Are you using eclipse or nightmode? A lot of app store apps were crashing upon start up until I put them on the "whitelist".
     
  17. crizza0309 thread starter macrumors regular

    Joined:
    Sep 4, 2008
    #17
    this fixed it! thank you!
     
  18. shenan1982 macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #18
    What does this mean? Nightmode? Whitelist? I just updated my iPad to 7.0.6 and having the issue. Apps open then crash. Doing a restore, but not overly confident it'll resolve it. I used pkgbackup. Don't really want to re-do everything one by one... ugh.
     
  19. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #19
    nightmode is a tweak that kinda turns your iOS all black
     
  20. shenan1982 macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #20
    I don't have that installed, or anything similar, yet all my apps are just starting then failing... ugh.
     
  21. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #21
    is it still the same in safe mode?

    if yes, if you sync your iphone to your computer, make sure the computer is authorized with your apple ID, same with in your settings panels on the iphone
     
  22. shenan1982 macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #22
    Thinking it was a corrupt pref file. Ended up just restoring, rejailbreaking and installing all of the same tweaks again and I expected it to not work, but low and behold, all works fine now, so I can only deduce it's a bad pref file or something funky that pkgbackup did. I will avoid pkgbackup again in the future. Too much hassle.
     
  23. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #23
    ^one the reasons why I prefer starting new. It may take longer and is more of a hassle but you at least know what happens. Unlike with automated processes
     
  24. shenan1982 macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #24
    Agreed. It's just a pain having to set everything up to look just the way I like it :) Especially since I have 2 iPhones and 1 iPad... guess the 7.0.6 update is necessary though given the security issues w\ 7.0.4
     
  25. psywzrd macrumors 68030

    Joined:
    Feb 6, 2008
    #25
    This is happening to me too after restoring to 7.0.6, jailbreaking, installing pkgbackup and restoring my jb apps, and then restoring from backup in itunes. I have tons of apps opening and then closing (Weather, Calculator, Mail and Safari just to name a few).

    Other than restoring and setting up as new (which I DO NOT want to do because it will be a huge headache for me), what can I do?

    Does it make sense to just remove my jb tweaks and reinstall them one by one?
     

Share This Page