Apps opening on startup

Discussion in 'Mac OS X Lion (10.7)' started by mgrady3, Aug 19, 2011.

  1. mgrady3 macrumors newbie

    Joined:
    Aug 10, 2011
    #1
    I know there have been a lot of questions about this:

    When I startup my computer into Lion three programs up, the same three every time, regardless of what is open when i restart, regardless of whether I uncheck that box in the shutdown window.

    iTunes, Chrome, and iTunesShut (a sleep timer for itunes) all open upon starting.

    I have checked sysprefs - login items nothing but ituneshelper
    I have checked the apps themselves in the dock to make sure they aren't set to open on login
    I have looked in my Library folders for Login Agents, Login Daemons etc; nothing

    I have looked in /User/Library/Saved Application States and trashed the following : Chrome, Finder, Itunes, iTunesShut

    still no dice

    I reset p-ram - nothing

    I booted into safe mode (holding shift upon restart) this did the trick
    but then booting back to regualr mode brings up the same problem


    any ideas?

    thanks.
     
  2. kayellare macrumors newbie

    Joined:
    Aug 17, 2011
    #2
    I had to click the usual red button to close out of the programs, but sometimes I have to go to the top bar by the Apple logo to "exit" them. Like, they act as if they're minimized sometimes, not actually quit.
     
  3. DReynolds86 macrumors newbie

    Joined:
    Aug 11, 2011
    #3
    Sounds like Resume is re-opening the applications when you restart? Do you "Quit" the programs before you shut down or just click the red X?
     
  4. mgrady3 thread starter macrumors newbie

    Joined:
    Aug 10, 2011
    #4
    I quit everything before shutting down

    The strange thing is that I am not even using these programs.
    I could be using text edit and nothing else, quit (cmd-q) that program, then restart and still Chrome, iTunes, and iTunesShut will open.

    I just deleted iTunesShut and downloaded the updated version from the app store, now called Berceuse; and yet still when I restart Lion tries to open iTunesShut but can't find it, so there is a question mark in the dock upon restart...
     
  5. sfoxy macrumors newbie

    Joined:
    Aug 19, 2011
    #5
    Exact,y the same thing started happening to me today! Mine opens 3 apps (not the same as yours) and the system preferences window at a page I was using last night.

    Basically it appears that the resume state is stuck! I have tired repairing permissions and the disk and that didn't help. I've tried having different windows open and leaving the option to re-open on login and still the same apps open.

    It comes at the same time that I have just had a shed load of problems with iCal duplicating hundreds of entries and then after I delete all the calendars they keep coming back. And I can't get some options to stick like I have tried turning off mobileme syncing and it just keeps coming back on.

    Something funny is going on since I upgraded to 10.7.1.

    Very frustrating.
     
  6. mgrady3 thread starter macrumors newbie

    Joined:
    Aug 10, 2011
    #6
    I also tried using the program Onyx to run the system maintenance scripts as well as trashing the boot cache, kernel cache among others.

    Now I'm frustrated because I upgraded iTunesShut to the new version called Berceuse and I have it set to "Keep in Dock" but when I restart my computer wants to open iTunesShut, which no longer exists so it replaces Berceuse in the dock with a question mark...


    Does anyone know if there's a way to reset the "Resume" preferences or cache or anything of that manner?

    I thought trashing the Saved Application States would do it but it didn't.
     
  7. sfoxy macrumors newbie

    Joined:
    Aug 19, 2011
    #7
  8. mgrady3, Aug 19, 2011
    Last edited: Aug 19, 2011

    mgrady3 thread starter macrumors newbie

    Joined:
    Aug 10, 2011
    #8
  9. sfoxy macrumors newbie

    Joined:
    Aug 19, 2011
    #9
    Ha ha,sorted it! Using info and link from one of the threads above, I followed the instructions here: http://reviews.cnet.com/8301-13727_7-10329971-263.html

    I used the fix to remove the ACL's on the home folder, so used those 2 commands in terminal - they take quite a while and I did get some errors but that doesn't seem to matter.

    Then rather than grabbing the Leopard DVD, I followed the info of this page: http://www.fixkb.com/2011/08/reset-home-folder-permissions.html about resetting the Home folders ACL's in Lion without a disk. The only thing I did differently was hold the Option key on startup and then selected the Recovery drive. I then opened the terminal and fixed the permission and on re-booting everything was fine. All preferences now sticking and no more apps at startup!

    Hope that helps you.

    Cheers.
     
  10. mgrady3 thread starter macrumors newbie

    Joined:
    Aug 10, 2011
  11. mgrady3 thread starter macrumors newbie

    Joined:
    Aug 10, 2011
    #11
    Totally works!

    Thanks for the tip!

    Here's a guide for anyone else who reads this-

    Log into your affected account (the lion account having problems with apps opening on startup)

    open the program Terminal (/Applications/Utilities/Terminal)

    type sudo chmod -RN ~
    press enter
    enter your password and pres enter

    (if you get an error message about a.plist not existing its ok)

    type sudo chown -R `id -un` ~
    press enter

    restart and hold option
    double click "recovery drive"
    when that boots up at the top there should be a "utilities menu"
    select Terminal

    type resetpassword
    press enter

    that should open an app;
    in that app select the harddisk that has the affected user installed on it
    at the bottom press the button to reset the access control lists and permissions

    quit that app
    quit the terminal
    in the top menu select restart

    voila!
     

Share This Page