Apps refused to download, now they won't go away

Discussion in 'iPhone' started by Zwhaler, Aug 19, 2008.

  1. Zwhaler macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #1
    I tried downloading two apps, and wanted to upgrade to the 2.0.2 software before the apps were finished downloading since I was getting annoyed by how long it was taking. I updated the firmware, synced the phone, and both apps (Flip Book Lite and the free Unit Converter) are stuck on "loading" and have been for an hour and a half, with no progress whatsoever. I am using wifi, so you think they would download faster. I even tried removing them from the "Applications" section in iTunes and then resyncing my phone. Did no good, and I can't even remove them from the home screen by tapping and holding n pressing the x... there isnt one! What do I do, these things won't download and I want them to go away.
     
  2. soberbrain macrumors 65816

    soberbrain

    Joined:
    May 9, 2008
    #2
    Have you tried going to the App Store and downloading the apps again? I got a message confirming that I had already downloaded the app and I just tapped OK to continue. That worked for me when an app seemed to freeze during installation.
     
  3. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #3
    +++
    Also, try doing a hard restart of the phone, should help in clearing anything stuck out of there.
     

Share This Page