iPhone Apps stuck in "Waiting..." state on iOS 7 Beta 3

Discussion in 'iOS 7' started by ajkessel, Jul 9, 2013.

  1. ajkessel macrumors newbie

    Jan 16, 2010
    I have about a dozen apps stuck on "waiting" then never finish visibly installing. However, if I find them in the App Store, I can open them from there; or from the task switcher. They just show up as ghosted on the App Launcher screen and can't be selected.

    I have seen various reports of similar problems and tried everything suggested. None of the following worked for me:

    - Restoring from backup
    - Power cycle
    - Airplane mode on/off
    - Log out of App Store and back in (with or without a reboot)
    - Remove apps from the device ("waiting" apps cannot be uninstalled -- there is no "X" icon after tap-and-hold)
    - Remove apps from the device with iTunes (if I try to remove from iTunes and then sync over USB, they remain on the device in "waiting" state; the change is ineffective)
    - Installing a new app; "pausing" the install with a tap; then resuming
    - Killing all tasks with the task switcher; then power cycle

    And various combinations of all of the above.

    I'm out of ideas. Any suggestions short of reverting to iOS 6?
  2. VSMacOne macrumors 601


    Oct 18, 2008
    Settings/General/Usage and delete each app that is stuck. Then re-install from iTunes or App Store.
  3. ajkessel thread starter macrumors newbie

    Jan 16, 2010
  4. hmckay12 macrumors newbie

    Jul 10, 2013
    I had a similar problem, except when I go to redownload the apps, it wont let me as they appear as if they are already downloading, any ideas? I've tried deleting all my apps from iTunes, re-syncing but the problem persists

    Attached Files:

  5. AtomicEdge macrumors regular

    Mar 23, 2009
    Just to chip in. I had an App stuck "Microsoft Lync 2013" and deleted it from the Usage page, but the app was still showing up on the launcher as "Waiting". I actually had to reboot the device after deleting it to get it to go away and I was then able to download it again from the App store and log in.

    A bit annoyingly, GoodReader also had this issue so I had to setup all my syncs and things again. (I know it's a beta, I am just saying!).
  6. petieg macrumors newbie

    Jul 31, 2007
    I just had this happen on both iphone5 and ipad mini after iOS7 upgrade and all i did was hold down one app so they all wiggle (as if to delete it), moved it around, and i saw that apps started to install... maybe it was timing but i believe i did the same thing w/ both devices.
  7. smartmobile macrumors newbie

    Sep 13, 2013
    How to fix apps stuck in "Waiting" WITHOUT reinstalling

    when you have apps stuck in "Waiting ..." after a restore from backup on iOS7, the app is actually fully installed and you can run it through the spotlight search, or through teethe store using the "OPEN" button.

    This is the reason why you are having problems uninstalling and re-installing, or have to use ITunes. Here is a way that seems to work every time WITHOUT having to uninstall or re-install anything.

    1- on your device, from Settings > iTunes& App Store, logout from the store.
    2- put the device in airplane mode
    3- Reboot the device (pressing power and home together, and NOT a simple power cycle)
    4- Once the phone is restarted, turn airplane mode off.

    You should see the apps in "Waiting " mode finish installing one by one, and get back to normal. when done, you can login to the store again.

    Et Voila !!!
  8. HD Boy macrumors newbie

    Nov 25, 2010
    In final IOS 7 version (after release) same problem with 65 Apps. The final
    Solution in this thread did not work for me.
  9. mangawing macrumors newbie

    Sep 19, 2013
    I'm having the same problem. all of my app after ugrading to IOS 7 can not work. I then deleted all of them and reinstalled the ipa files stored on my Itune. After installing all the apps are still in waiting ( the icon is dark , although Itune says it finshed syncing )

    Try the reboot method from smartmobile and it still doesn't work

    Any help ???
  10. Kiddosmart macrumors newbie

    Sep 21, 2013
    App stuck in waiting

    Try these simple steps:

    Just press all the "pause" (blue square) button beside apps in the appstore.
    Then you can try updating apps one at a time

    *App usually stalls when your internet connection is not strong and stable enough to accommodate large file size updates.
  11. texage macrumors newbie

    Sep 23, 2013
    Apps stuck in waiting

    I am surprised there are so few comments about this issue. I have been plagued by this in every update from 3GS to 4 to 4S to 5 and now to 5S on three different home machines. I have never successfully restored a phone from iTunes without 50 to 100 apps getting stuck and requiring individual deletion and re-download. With each new iTunes version or phone update, I hope for some difference but it never comes.
  12. mowcook macrumors newbie

    Feb 1, 2014
    Thank God!!! FIXED

    Smartmobile, thank you! I just read your directions to clear this problem I WAS having with my iphone 4. Seems like I wasn't the only one. I followed your directions which were easy enough. All the apps have updated and finished downloading. Two weeks, I have been going thru this and ready to pull my hair out. Thanks for your help. You are my Hero!!:)

Share This Page