Apps that inadvertently require 4.0

Discussion in 'iOS Apps' started by jtara, Jun 24, 2010.

  1. jtara macrumors 65816

    Joined:
    Mar 23, 2009
    #1
    This post is for a list of apps that have been updated since the release of iOS 4 and (apparently inadvertently) REQUIRE 4.0.

    Now, this might be expected for a few new apps, as well as perhaps older ones that sorely need 4.0 functionality.

    But, in many cases, app authors have goofed, and required 4.0 when they hadn't intended to. Not only that, some of these apps have their compaatability set incorrectly in the app store, and you won't even be successful downloading them. It will try, then say that the version is incompatible.

    (For the developers out there, the "right way" is to set the Base SDK to 4.0 and the Deployment Target to the earliest version you want to support. Newer frameworks need to be checked in code or weak-linked, and newer methods on older frameworks need to be checked in code before using them.)

    Also, indicate if the author has noted the error and stated that they will be correcting it.

    Unfortunately, if you do an "update all", it will download these newer, incompatible versions. You will need to update app individually to avoid this.
     
  2. jtara thread starter macrumors 65816

    Joined:
    Mar 23, 2009
    #2
    Here's mine so far:

    8500+ Drinks & Cocktail Recipes Free 2.1.0 author has noted error, promised to correct in future release

    Loopt 3.0 requires iOS 4.0

    TideApp 2.9 requires iOS 4.0
     

Share This Page