Apps without 3.1 firmware?

Discussion in 'iOS Apps' started by polobreaka, Sep 14, 2009.

  1. polobreaka macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #1
    are most developers updating their apps to work only with 3.1 firmware? and if you stay in 3.0.1 or below, you're pretty much screwed?

    for example....yelp. they updated, but it only works with 3.1 FW.
     
  2. DipDog3 macrumors 65816

    DipDog3

    Joined:
    Sep 20, 2002
    #2
    The developers that are still active probably are.

    You might as well update because no developer is going to waste time supporting old firmware.
     
  3. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #3
    If you still have a substantial user base on the old firmware, it would be silly to not continue to try to support them. There are still plenty of iPod touch owners out there who have been reluctant to upgrade to 3.x because of the fee.
     
  4. Jeremy1026 macrumors 68020

    Jeremy1026

    Joined:
    Nov 3, 2007
    #4
    Disagree. I am a developer and many of my apps run on 2.x Not everyone updates, and unless you use 3.x specific features it is limits my possible user base.
     
  5. Menge macrumors 6502a

    Menge

    Joined:
    Dec 22, 2008
    Location:
    Amsterdam
    #5
    Well, there is still a large user base on 2.2.1 due to the iPod Touch upgrades being paid. I, for one, have just submitted a game to the App Store (Undead Attack! Pinball - check it out in a couple of weeks :p) that still supports the 2.2.1 firmware.

    I don't think developers should drop support for 2.2.1.
    HOWEVER, support for 3.0 and 3.0.1 will be dropped quickly by most due to the fact that people can freely upgrade to 3.1.
     
  6. polobreaka thread starter macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #6
    but if 3.0 and 3.0.1 has nothing wrong with most user...why wouldnt they be supported? i for one probably wont upgrade to 3.1 yet just because i am fine where i am at.

    isnt 2.2.1 older than 3.0/3.0.1? supporting older firmware rather than later ones seems ...dumb?
     
  7. Jeremy1026 macrumors 68020

    Jeremy1026

    Joined:
    Nov 3, 2007
    #7
    If an app runs on 2.x, then it will run on 3.x. But NOT the other way around. It is dumb to only support 3.x unless you are using 3.x specific features, like push notifications.
     
  8. vettori macrumors 6502a

    Joined:
    Jul 10, 2008
    Location:
    Italy, near Venice
    #8
    I'll never put an OS requirement on an app unless it really needs it.
     
  9. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #9
    Dumb? What makes you think that?
     
  10. Menge macrumors 6502a

    Menge

    Joined:
    Dec 22, 2008
    Location:
    Amsterdam
    #10
    Thing is: sometimes an OS upgrade breaks things. Even if there weren't many features introduced. To test on a specific OS version, you need the actual device. The simulator, sometimes, isn't good enough. This is true specially for games.

    3.0 -> 3.0.1 didn't break anything. 3.0.1 -> 3.1 has new APIs (particularly helpful for gaming), so if you want better frame rates on games, you need to write specific code for 3.1 and specific code for older versions. This is work. Sometimes a developer doesn't have the hardware/time to test on all possible OS combinations. Sometimes he just doesn't want to.

    It's not dumb to support 2.2.1 and not 3.0/3.0.1, but support 3.1. It's actually a sale strategy.
    2.2.1 -> 3.X is a paid upgrade for iPod Touch users, so lots of people will stick to 2.2.1.
    3.0/3.0.1 -> 3.1 is a free upgrade for everyone. Anyone can do it and they SHOULD do it. So dropping 3.X OSes before 3.1 makes sense because it'll push people forward. And this won't cost anything to those people.
     
  11. polobreaka thread starter macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #11

    thanks for the explanation. i didnt understand it at first, thats why i thought it was dumb. :apple:
     
  12. kainjow Moderator emeritus

    kainjow

    Joined:
    Jun 15, 2000
    #12
    Do you have the ability to test and support every OS on every hardware?
     
  13. vettori macrumors 6502a

    Joined:
    Jul 10, 2008
    Location:
    Italy, near Venice
    #13
    I can't test all combinations (actually I have three) but, as far as I know, the OS works in a consistent way across different hardware.

    If I need some feature that is available only on OS3 than the app will require OS3, otherwise I'll code the app using only features available on both OS2 and OS3.

    A developer can also code an app that knows on which OS version is running and enables some features only if the OS supports them.
     
  14. return7 macrumors 6502

    Joined:
    Oct 8, 2008
    #14
    'nough said. holds true most of the time (can't think of a case where it wouldn't, actually -- would be some odd quirk)
     
  15. vettori macrumors 6502a

    Joined:
    Jul 10, 2008
    Location:
    Italy, near Venice
    #15
    Well I found an issue on my app ABContacts where the app was working on OS2 but not on OS3 because of a deprecated method. But if we keep the app "current" there should not be any issue like this.
     
  16. jediknight0 macrumors newbie

    Joined:
    Aug 20, 2008
    #16
    As a somewhat newly minted developer myself, I can think of another reason for 3.0 only (and up) support - snow leopard.

    Unless I'm missing something, the SDK for snow leopard only includes 3.0 & up as possible targets.
     

Share This Page