Apps won't download on cellular

Discussion in 'iPhone' started by noobinator, Sep 28, 2015.

  1. noobinator macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Los Angeles, CA
    #1
    I know this is more of a T-Mobile problem probably but has anyone had any trouble downloading apps on cellular? For awhile now, going back to the iPhone 5 probably I've never had any sort of consistency downloading apps on cellular. I usually have to wait until I get home and do it on WiFi. This is most painful when doing a restore. I get the "Unable to download, please try again later". If I'm extremely persistent I can usually get them downloaded after a few dozen errors or so.

    Anyone else? Any suggestions?
     
  2. nuuuuts macrumors newbie

    Joined:
    Jul 2, 2011
    #2
    I've run into the same issue lately and I'm on tmobile. Never really had an issue before when I was with ATT. It's a pain when trying to download a new app. It seems if you put the phone in airplane mode then out of airplane mode, I'm able to download from the app store.
     
  3. nandopr macrumors regular

    nandopr

    Joined:
    Jul 17, 2008
    Location:
    Orlando, FL
    #3
    I am with AT&T. Can't download app updates using cellular. Don't know about wifi because there is none where I am now.
     
  4. mzengr macrumors member

    mzengr

    Joined:
    Nov 11, 2014
    #4
    I had this problem earlier and I'm on Sprint. I read in another forum that someone in the same city as I am was having the same problem and she's on AT&T. Maybe the App Store is/was down.
     
  5. techiegirl macrumors 6502a

    techiegirl

    Joined:
    Sep 7, 2007
    #5
    I've had this problem for several weeks now. It usually would download after I power-cycle the phone.
     
  6. nuuuuts macrumors newbie

    Joined:
    Jul 2, 2011
    #6
    yea power cycle works; actually i've started to have issues probably within the last month or so. I did have a 6plus and attempted to do restores and still had the same problem. When I switched to the 6s plus with the tmobile promo I was hoping that it might've been a phone issue or ios8 issue but with ios9 and the new phone still having the same problem. I'm hoping that things will fix itself.
     
  7. edlex, Sep 29, 2015
    Last edited: Sep 30, 2015

    edlex macrumors 68000

    edlex

    Joined:
    Apr 14, 2010
    Location:
    Miami, FL
    #7
    I'm on Sprint and no problems updating or downloading apps. It's funny because I always get the warning when it's over 100mb to retry when on wifi but it downloads anyway.
     
  8. sjperformance macrumors 6502

    Joined:
    Oct 7, 2013
    #8
    I'm on AT&T and I'm constantly having this issue too.
     
  9. MarkZinger macrumors member

    Joined:
    Sep 20, 2015
    #9
    T-Mobile here, apps fail to download over cellular maybe half the time I try to download something. Doesn't seem to be any solutions as of yet.
     
  10. thelead macrumors 6502

    Joined:
    Apr 30, 2010
    #10
    Glad I'm not alone. This has been an issue for me on AT&T.

    Strangely, everything else (cellular data related) is working fine...
     
  11. noobinator thread starter macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Los Angeles, CA
    #11
    Restarts don't help me. I mess with signing in and out of my account and then moving the time a year forward and back. After this it usually downloads eventually. I found it best to just wait for wifi but that isn't always an option.
     
  12. Cubano21 macrumors member

    Joined:
    Dec 12, 2012
    #12
    Same issue here on AT&T. Web, Instagram, FB, Twitter, iMessage etc worked just fine but downloading apps and some issues in Apple Music. Weird thing App Store home page and search worked fine but couldn't DL. Apple Music would not play from connect and some songs in different playlist would stop or skip. All this while I was 4-5 bars with lte. I hope this is just a bug on Apples end.
     
  13. docprego macrumors 65816

    Joined:
    Jun 12, 2007
    Location:
    Henderson, NV
    #13
    Same problem here on T-Mobile. Downloads seem to get near completion and fail. I can sometimes try 3-4 times on a single app and all fail but then it will randomly complete the download on a subsequent attempt. There's no rhyme or reason to it.
     
  14. Zimmy68 macrumors 65816

    Zimmy68

    Joined:
    Jul 23, 2008
    #14
    There is a thread on the iOS9 board about it. Thought it was only an AT&T thing.

    It might be a 9.0.1 issue.
     
  15. noobinator thread starter macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Los Angeles, CA
    #15
    It's been happening to me for over a year but more the last 3-4 months.
     
  16. thelead macrumors 6502

    Joined:
    Apr 30, 2010
    #16
    This has been happening for a few months for me... Kinda hard to pinpoint but definitely before iOS 9 and on three different iPhones.

    Maybe it's unrelated but the hotspot feature has also gone to crap over the last few months as well.
     
  17. noobinator thread starter macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Los Angeles, CA
    #17
    My hotspot on T-Mobile is horrible also. I use it as a wifi hotspot only and it takes forever to show up on my other devices as a hotspot. Sometimes I can't get it to show up at all. Is this what yours does or is the performance just bad once connected?
     
  18. Cubano21 macrumors member

    Joined:
    Dec 12, 2012
    #18
    Looks like Apple just released another update 9.0.2. It states it fixes a cellular bug fix. Fingers crossed.
     

    Attached Files:

  19. Zimmy68 macrumors 65816

    Zimmy68

    Joined:
    Jul 23, 2008
    #19
    You can uncross your fingers, still doesn't work. Update did nothing to fix it.
     

Share This Page