Apps won't update?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by OhioLefty, Feb 5, 2011.

  1. OhioLefty, Feb 5, 2011
    Last edited: Feb 5, 2011

    OhioLefty macrumors regular

    Joined:
    Aug 7, 2009
    #1
    I recently run into a problem where my app updates on my JB iPhone 3GS on iOS v3.1.2. My iPhone won't let me update the apps that have updates. When I tap the "Update" button I get the "Install" button but when I tap the "Install" button it just kicks me back to the "Update" button. I've tried rebooting, respringing, hard reset and logging out of iTunes on my iPhone and logging back in and none have worked. The only way I can update is to download the updates in iTunes and "Sync" to get the updates and that works as it should, apps are updated. I'm pretty sure the updates were under 10MB and I am on Wi-Fi and my wife was able to update the exact same apps sitting right beside me on a non JB iPhone 3GS but running iOS 4.x.x This just started a few days ago.

    One other thing, I am able to download and install new apps. :confused:

    Any ideas? :confused:

    Thanks...
     
  2. Wkevfm macrumors newbie

    Joined:
    Feb 6, 2011
  3. Mrtax, Feb 8, 2011
    Last edited: Feb 8, 2011

    Mrtax macrumors newbie

    Joined:
    Feb 8, 2011
    #3

    Also i yesterday started noticing some apps won't update
    The app blu install button press turns into green update (with small + sign : i think it's a sign for universal update!) and reverse.http://images.macrumors.com/vb/images/smilies/mad.gif

    I olny can update with iTunes ( i have also the bug white page in appstore with itunes 9.1.1.12 :-( ) on PC and after syncing.


    PLEASE APPLE fix it on your repo/appstore web!!!!! http://images.macrumors.com/vb/images/smilies/frown.gif http://images.macrumors.com/vb/images/smilies/mad.gif

    PS other people have the same problem : http://discussions.apple.com/thread.jspa?messageID=13053623
    http://images.macrumors.com/vb/images/smilies/mad.gif

    also here http://discussions.info.apple.com/thread.jspa?threadID=2745583&tstart=0
     
  4. OhioLefty thread starter macrumors regular

    Joined:
    Aug 7, 2009
    #4
    You described the problem on the iPhone perfectly! I don't have any problem updating on my PC via iTunes and my wife can update on a non-JB iPhone 3GS, identical to mine, same apps, no problem.
     
  5. pauliedoggs macrumors member

    Joined:
    Oct 13, 2009
    #5
    I am having the same problem although my 3GS is not jailbroken. I haven't tried updating thru iTunes yet. I will try that for now. Anyone have any idea when Apple is going to fix this?
     
  6. Lycanthroat macrumors regular

    Joined:
    Jan 11, 2011
    Location:
    UK
    #6
    Same here, I've got it too - I just press the "Update All" and it works fine.

    Weird how it just flips from UPDATE to INSTALL forever though, if you try and update the app by itself. I'm on 3.1.3, 3G.
     

Share This Page