appstore apps won't install?

Discussion in 'Jailbreaks and iOS Hacks' started by theinvid, Aug 19, 2010.

  1. theinvid macrumors newbie

    Joined:
    Dec 13, 2009
    #1
    Jailbroken iPhone4 on 4.01

    This morning I accepted new iTunes terms.
    Downloaded some updated except for the newest Facebook (heard about the problems)

    Attempted to download a couple of free games from Appstore today and I click on 'install' and then the app crashes and I'm back on homescreen but nothing is downloading.

    I've tried a respring (didn't fix it)
    I've tried a Hard Reboot (holding both home button and lockscreen button down until it reboots) (didn't fix it)

    Any ideas???

    I'd hate to have to do a total restore.
     
  2. Myzhi macrumors 6502a

    Myzhi

    Joined:
    Dec 15, 2009
    #2
    What apps have you installs through Cydia and/or Rock? Try uninstalling them one by one and see if it fixes your problem.
     
  3. rmul86 macrumors 6502

    Joined:
    Jul 9, 2010
    Location:
    Boston, MA
    #3
    I need a little more information. Are you by any chance using categories? Have you downloaded any cydia apps yet? Every so often when I use categories my ability to download apps from the app store is lost. So I have to move the app store from my categories folder and then it works again.
     
  4. theinvid thread starter macrumors newbie

    Joined:
    Dec 13, 2009
    #4
    Yup, I have the AppStore in a categories folder. Took your advice and now it works! Hooray!
    Hmmm can I put it back in the folder and have it work?
     

Share This Page