Appstore doesn't work

Discussion in 'iPod touch Hacks' started by SkylerZio, Jun 6, 2010.

  1. SkylerZio macrumors newbie

    Jun 6, 2010
    3G 3.1.3 MC011LL Spirit JB

    Since JBing, I had not tried the appstore, until I got an update for a program I bought. When I tried to Update i get the "waiting..." message when a program is about to download, then i get a pop up that says "Unable to Download Application. [Program Name]will be available for download when you log into iTunes store on your computer"

    I checked for updates in iTunes, and it downloads the updates, But nothing happens when I sync the iPod with iTunes.

    1) is there a way to update my purchased apps through appstore on iPod?
    2) How can I get my apps to sync?
    3) Am I missing some plug-in for a Jailbroken iPod to be able to do this stuff?

    I searched the web and Have tried various things, but they were all suggestions from ~2years ago, nothing recent.

  2. DisneyRicky macrumors regular


    Jun 5, 2010
    Northern California
    Must have been a glitch when you were patching during the jailbreak. Do a restore and Jailbreak again, should fix your problem.
  3. SkylerZio thread starter macrumors newbie

    Jun 6, 2010
    ok I will try that, But before I do, How can I save my stuff? Since I can't sync to iTunes, I don't want to loose all my information/save games or have to hunt for all my programs again. I've heard about this program called Applesync, does that work?
  4. mrhappyface2010 macrumors newbie


    Jun 18, 2010
    Just try Applesync or just restore your iPhone then rejailbreak, took me 10 seconds with Spirit! ;)

Share This Page