AppStore Update Badge stuck

Discussion in 'iOS Apps' started by erasat, Feb 1, 2010.

  1. erasat macrumors member

    Joined:
    Aug 21, 2009
    #1
    First, I have searched dozens of forums including this one for this error, and in a summary all of them just say that this eventually go away and that it can take up to a week.

    Well, with that in mind, let me give you details; on 1/23/10, there was an update for WhatsApp Messenger, I immediately connected to the AppStore and update it from there, for my surprise, a couple of minutes later there it was another Update badge, when I opened it was for WhatsApp again, to make it short I have downloaded and Updated WhatsApp (Including removing both, the iPhone and the iTunes copy) more than 25 times since that day, even after a complete Restore of the iPhone.

    Just in case I contacted WhatsApp support to see if this happened to anybody else after the update and according to their response I'm alone on this one, but they also told me the same, that they have seen this before and it will eventually go away. Problem is that it has been 9 days already, and you don't know how annoying it is for me to see any kind of badges in the App icons, it simply drives me crazy not been able to solve it. Not to mention that I contacted Apple Support and it was simply frustrating just waiting for them to just refer me to their iPhone FAQ.:mad:

    So, the reason I'm writing here is simple, do you think is there any other way to fix this not just by waiting to see if it finally goes away? Thanks in advance guys.
     
  2. erasat thread starter macrumors member

    Joined:
    Aug 21, 2009
  3. noah82 macrumors 6502a

    noah82

    Joined:
    Oct 16, 2008
    Location:
    San Diego, CA
  4. erasat thread starter macrumors member

    Joined:
    Aug 21, 2009
    #4
    Sorry I think I was drunk when I typed this:D, I just fixed the typo in the title.

    Now to the topic, really, nobody know anything about this issue? It is still driving me crazy.
     
  5. jkb macrumors regular

    jkb

    Joined:
    Mar 13, 2009
    Location:
    California
    #5
    delete whatsapp from iphone and itunes library.

    upgrade iPhone to 3.1.3

    download whatsapp directly to your iphone from the link in my signature.
     
  6. erasat thread starter macrumors member

    Joined:
    Aug 21, 2009
    #6
    Thanks for replying.

    Well, that can be a solution, only problem with that is that I'm jailbroken, and if I upgrade to 3.1.3 then I will loose it, and sincerely, there is no way I will loose my ProSwitcher, my Custom Themes and others. I prefer to see the annoying badge to loose my JB, if it keeps doing it, and there is a JB solution for 3.1.3 soon, I will try your suggestion. Thanks.
     
  7. daisyandy macrumors newbie

    Joined:
    Feb 16, 2010
    #7
    I have the same problem... Only mine got stuck with a Beejive update. And it drives me crazy too to see that little number on the AppStore icon! It's been 6 days!
     
  8. erasat thread starter macrumors member

    Joined:
    Aug 21, 2009
    #8
    Well, then according to SandynJosh you also suffer from OCD, so you are the one that are wrong...:rolleyes:

    BTW, I was just hoping that with a new Update from WhatsApp (At least in my case is the App that's stuck) that the da*n badge will be gone forever, but guess what?, a new update last night, Version 2.5.1, I updated it and the same thing is still happening, still keeps telling me that there is a new update available...:mad:

    Worst thing is that calling Apple is just a waste of time, like I mentioned before, they just refer me to the FAQ, and I also have tried the From-Scratch-Restore and still the same so I won't go that route again, in other words, lucky all of you that doesn't suffer from OCD ;), or/and had this issue before and it just simply went away, because in my case it has been almost a month and still the same.
     
  9. iFerd macrumors 6502a

    Joined:
    Jul 20, 2007
    #9
    I'm reasonably sure you will find at least one thread about this or at least a similar problem. I know there was a period of time when I had similar troubles. I'd update applications, only to have the notice that I needed to update reappear. That disappeared some time ago, though. I'm not sure if it was a change on the App Store end or one of the firmware updates, but I haven't seen this in quite awhile.
     
  10. erasat thread starter macrumors member

    Joined:
    Aug 21, 2009
    #10
    Update:

    3 months later, some What's App updates, 3.1.3 Firmware upgrade, re-jailbrake, and I'm still having the same da*n issue. I have searched hundreds of posts across the web and most if not all just mention that it will eventually go away, so my question is when?

    After I updated to 3.1.3 and just before I restored from my latest backup, I did test a couple of times and there was no Update issue, once I restored (I obviously needed to do it, otherwise, I need to redo all my settings and stuff) first thing I saw once it rebooted was the # 1 in the App Store, when I entered, there it was, same old 3/30/10 What's App update waiting for me to download it for the 50th time.

    So, as you can see, it's strictly related to something on my settings, and it's getting saved with every backup, so what exactly is it?, Apple never respond, and so far I haven't found the response online.
     
  11. erasat thread starter macrumors member

    Joined:
    Aug 21, 2009
    #11
    Hi JKB.

    I also tried your suggestion, I upgraded to 3.1.3, I deleted both, my iPhone and iTunes versions, went to Safari and followed the link, it just opened APP store, and there it was already, the Update available, even without the App installed in the iPhone.

    Any other suggestion?
     

Share This Page