Apricorn Velocity V2 solo in 2012 MP

Marty62

macrumors 6502
Original poster
Mar 11, 2010
394
0
Berlin formerly London
Stunning ! ... really, I'm blown away.

Samsung EVO 750 (or any SSD) screws onto the card, this takes 2 minutes.

It receives power direct from the card, no cables.

Install in PCI slot, another 2 minutes.

Instantly recognised by the MP ( 10.8.5 installed previously )

Boot time from "chime" 15 seconds !!

VERY impressed, so simple and fast, full SATA III 6GB/s connection.

Bought from Expansys yesterday afternoon and delivered this morning at 9am.

I would recommend this to any 3,1 / 4,1 / 5,1 MP owner.
 

Macman45

macrumors G5
Jul 29, 2011
13,196
133
Somewhere Back In The Long Ago
Stunning ! ... really, I'm blown away.

Samsung EVO 750 (or any SSD) screws onto the card, this takes 2 minutes.

It receives power direct from the card, no cables.

Install in PCI slot, another 2 minutes.

Instantly recognised by the MP ( 10.8.5 installed previously )

Boot time from "chime" 15 seconds !!

VERY impressed, so simple and fast, full SATA III 6GB/s connection.

Bought from Expansys yesterday afternoon and delivered this morning at 9am.

I would recommend this to any 3,1 / 4,1 / 5,1 MP owner.

Yep, had one on test in a 5.1 Hex, and it flew...highly recommended
 

Robert Davies

macrumors 6502
Jul 28, 2011
316
3
People's Republic of Wrexham
Stunning ! ... really, I'm blown away.

Samsung EVO 750 (or any SSD) screws onto the card, this takes 2 minutes.

It receives power direct from the card, no cables.

Install in PCI slot, another 2 minutes.

Instantly recognised by the MP ( 10.8.5 installed previously )

Boot time from "chime" 15 seconds !!

VERY impressed, so simple and fast, full SATA III 6GB/s connection.

Bought from Expansys yesterday afternoon and delivered this morning at 9am.

I would recommend this to any 3,1 / 4,1 / 5,1 MP owner.

Where did you source your Velocity x2 from? If you have a link, that would be a big help! :)

The reason I ask, is that in searches I can only local the v1 model.

Thanks!

-Rob
 

rhp2424

macrumors regular
Jul 23, 2008
117
10
Where did you source your Velocity x2 from? If you have a link, that would be a big help! :)

The reason I ask, is that in searches I can only local the v1 model.

Thanks!

-Rob
Rob, is this the one you are looking for?
www.amazon.com/Apricorn-Velocity-Extreme-Performance-VEL-SOLO-X2/dp/B0090IA3GY/


ive got a 1TB samsung evo connected to it and it is very fast...
I've got the same setup (though the x2 version) and I too am very very pleased.
 

brentsg

macrumors 68040
Oct 15, 2008
3,410
767
I've been running a pair of Velocity X2's in a RAID0 config for a very long time with no problems.
 

CrazyNurse

macrumors regular
Oct 23, 2012
147
3
I just installed mine, too!

Very impressed so far.

I'm running a long SATA cable from the extra port to my optical drive bay for whenever I add on a 2nd SSD to this card.
 

kennyman

macrumors 6502
May 4, 2011
254
35
US
I've been running a pair of Velocity X2's in a RAID0 config for a very long time with no problems.
I have also been thinking on doing a RAID 0 for OS and apps. Could you please post transfer speed of your RAID 0 drives. I currently have 1 pcie data card which is similar to the X2 in speed and have 1 x 256 GB samsung SSD. Thinking of getting another one.
 

kennyman

macrumors 6502
May 4, 2011
254
35
US
I have also been thinking on doing a RAID 0 for OS and apps. Could you please post transfer speed of your RAID 0 drives. I currently have 1 pcie data card which is similar to the X2 in speed and have 1 x 256 GB samsung SSD. Thinking of getting another one.
Updates: Never-mind, just bought 1 more SDD and did a Raid 0, installing OS right now.
 

brentsg

macrumors 68040
Oct 15, 2008
3,410
767
Good luck. It's been stable and fast enough.

For general use I'd say the overhead probably wipes out any transfer rate advantage, but I haven't spent much time benchmarking it. It's fast.. and I mostly needed the extra capacity since I had a pair of 180GB SSDs.
 

m4v3r1ck

macrumors 68020
Nov 2, 2011
2,341
347
The Netherlands
Stunning ! ... really, I'm blown away.
Samsung EVO 750 (or any SSD) screws onto the card, this takes 2 minutes.
It receives power direct from the card, no cables.
Install in PCI slot, another 2 minutes.
Instantly recognised by the MP ( 10.8.5 installed previously )
Boot time from "chime" 15 seconds !!
VERY impressed, so simple and fast, full SATA III 6GB/s connection.
Bought from Expansys yesterday afternoon and delivered this morning at 9am.
I would recommend this to any 3,1 / 4,1 / 5,1 MP owner.
This PCIe card is one of my best upgrades in MP 3.1! Congrats on your purchase!

GL & Cheers