Apt Backup-Useless or user error?

Discussion in 'Jailbreaks and iOS Hacks' started by Enigmafan420, Nov 24, 2008.

  1. Enigmafan420 macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #1
    I am COMPLETELY FRUSTRATED with apt backup. I have NEVER BEEN ABLE to make it work-3rd software upgrade and it DOES NOT WORK :mad:

    I pwned 2.2, restored, and restored my iphone-Ran CYDIA first thing and downloaded aptbackup. When I choose restore, it says "restore can only happen after a backup has been performed and the iphone has been restored" WHICH IS WHAT I FREAKIN DID!!!!!

    URGH-what am I doing wrong??? :mad:
     
  2. freitas macrumors member

    Joined:
    Jan 27, 2008
    Location:
    Ohio, USA
    #2
    Same here... I though I followed the instructions pretty well.
     
  3. enophi1 macrumors 6502a

    enophi1

    Joined:
    Nov 23, 2008
    Location:
    UK
    #3
    I have heard aptbackup wont work on 2.2 ? I don't know if this is true or not, but I am hoping to utilize it as well.
     
  4. LoMonkey macrumors regular

    Joined:
    Jul 4, 2008
    #4
    Hmmm, thought it was just me.
    AptBackup hasn't been working for me since 2.0.2

    Useless IMO.
     
  5. chas0001 macrumors 6502a

    chas0001

    Joined:
    Sep 18, 2006
    Location:
    Alicante, SPAIN
    #5
    I am glad its not just me. I did the backup, synced but when I came to restore it said that I need to backup first. Luckily I wrote down all the Cydia apps I had installed.
     
  6. thesoze macrumors newbie

    Joined:
    Nov 25, 2008
    #6
    yea, the program is a waste - i did what it told me to do then it said I must backup...WTF?
     
  7. TheConfuzed1 macrumors 6502a

    Joined:
    Jun 4, 2003
    #7
    I even went so far as to restore from back-up twice. Before loading AptBackup, and after. It didn't work either way.

    There are two possibilities that I see:

    1. It's crap.

    2. It's not yet updated for 2.2 firmware. If this is the case, it is inexcusable, conisdering that updating firmware is the biggest reason why most of us would even need this app.

    Either way, it's crap.

    I've manually been customizing things back to the way that I like them, and I actually think in the long run, it may be better this way, as I now am not downloading things that I know I won't use, or don't need.

    I am very disappointed in AptBackup.
     
  8. guyverzero macrumors member

    Joined:
    Jun 22, 2008
    #8
    its worked for me in 2.0.2 through 2.2 just last night. You have gotta back it all up, and when you pwn your phone, after that you must restore from a backup on your iphone. Choose the most recent one (reccomended sync right before pwning) and directly after that go into cydia, download NOTHING but apt backup and press restore.

    It says right in the instructions to do nothing before this, maybe you're doing somehting like adding songs before doing this. The only other thing I can think of is that you're not restoring from your phones back up previously. If you don't do that, it won't know anything you got.
     
  9. xsecretfiles macrumors 6502

    Joined:
    Aug 1, 2008
    #9
    You know, it's weird. It worked for me when I moved from 2.01 to 2.02, maybe it was missing a program or two

    But when I tried it with my sister phone, it didn't work at all. I always got the same message.."after backup something something."

    I'm wondering whether it only works when you backup and syn using a Mac, which is when I got mine to work

    However my sister did her backup on windows....
     
  10. mdecker79 macrumors member

    Joined:
    Jul 14, 2008
    #10
    It worked for me when I just upgraded 2.1 to 2.2. I used it to backup my installed jailbreak apps. Did a backup in iTunes and then upgraded to 2.2. Ran Quickpwn and installed aptbackup. Opened it and selected the restore option and when I came back a few minutes later all my apps were back installed.
     
  11. Enigmafan420 thread starter macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #11
    I did everything you did, except I used pwnage tool because I want to keep the possibility of an unlock in place. SO I didn't do the Apple update-I went straight to pwned 2.2.

    I still got that FREAKING error about backing up first. And I DID do a back-up right before pwning.

    I dunno-maybe I am stupid on this thing?!?
     
  12. bradenwh macrumors 6502

    Joined:
    Apr 12, 2008
    #12
    Sigh.

    I'm just making sure everyone knows that you have to restore from your backup after you've restored so AptBackup knows what to redownload, right? AptBackup worked for me on 2.2.
     
  13. CocoaPuffs macrumors 68010

    Joined:
    Aug 23, 2008
    #13
    Most people choose to ignore the prompt in iTunes about restoring. I always get calls from friends asking how come they lost all their information on the phone.
     
  14. Enigmafan420 thread starter macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #14
    I did restore as soon as the 2.2 was installed and verified. I still lost all my jb apps. It doesn't matter anymore, I am where I was before the 2.2 install. A very frustrating experience to say the least.
     
  15. TheConfuzed1 macrumors 6502a

    Joined:
    Jun 4, 2003
    #15
    It has nothing to do with that. I tried (and failed) with a Mac. I don't do Windows.

    And yes, I restored from backup... twice.
     
  16. Warbrain macrumors 603

    Warbrain

    Joined:
    Jun 28, 2004
    Location:
    Chicago, IL
    #16
    From my own experience it's entirely worthless. Never worked.
     
  17. CocheseUGA macrumors member

    Joined:
    Aug 27, 2008
    #17
    If you follow these steps, you shouldn't have a problem.

    Open AptBackup.
    Click Backup.
    Do a full sync and backup through iTunes.
    Upgrade.
    Jailbreak.
    Sync in iTunes.
    Download AptBackup.
    Click Restore.
    Do another full sync and backup.

    Done. Worked beautifully.
     
  18. Bear Hunter macrumors 6502a

    Bear Hunter

    Joined:
    Aug 10, 2008
    #18
    Didn't work for me and a lot of others who performed those exact steps
     
  19. Enigmafan420 thread starter macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #19
    Yeah exactly what I did-no go-I dunno what I did wrong-I KNOW I had a good backup because it was the last thing I did prior to JB. :confused:
     
  20. Maceddy macrumors newbie

    Joined:
    Dec 28, 2003
    Location:
    Australia / Indonesia
    #20
    yep piece of garbage

    Just doesn't work.
    I have tried it the way the instructions specify.
    Tried it according to these instructions.
    I even went to the trouble of loading all my Cydia apps, doing a back up, then deleting all my Cydia apps and restoring from the backup.
    Just doesn't work.
    Piece of garbage and needs some updating and major work before I'll use it again.
    Hope I didn't pay for it I can't remember now ?
     
  21. Knowlege Bomb macrumors 603

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #21
    I gave it a shot - and followed the instructions to the letter - and was told I had to back up before I restore. Just like 90% of the other people who tried it.

    Guess it's just hit or miss?
     
  22. Dominus macrumors newbie

    Joined:
    Nov 28, 2008
    #22
    For me the error was not doing a sync after I did aptbackup, I just went straight to the pwnage tool process
     
  23. blaksmooth macrumors newbie

    Joined:
    Aug 5, 2008
    #23
    Apt Backup - A Success!!

    I just thought I'd let you guys know that after a successful 2.2 upgrade and successful 2.2 Jailbreak, Apt Backup worked like a charm.

    It seems as though the key is to load Apt Backup IMMEDIATELY after you Jailbreak, and have already restored from your backup file in iTunes.

    I did it wrong with 2.1 but was successful this time.

    Hope it helps someone, it worked great. Kept almost all (all but one) of my themes in place in Winterboard as well!!

    Blak-
     
  24. Enigmafan420 thread starter macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #24
    So you restored the back-up then downloaded aptbackup?

    This is what I did-and got that friggin error message. I may try again next software update, just for fun-or when I upgrade my Wife's phone to 2.2 I may try it. But it doesn't sound like you did anything different than I did?!? :confused:

    Edit: I may have actually downloaded SSH and/or Boss preferences first-really do not see why that would matter though.
     
  25. Enigmafan420 thread starter macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #25
    It FINALLY Worked

    I just updated the wife's iPhone to 2.2 and aptbackup actually WORKED. I can't believe it-it is restoring right now.

    I guess my error was installing ANY Cydia apps before aptbackup. Last time I tried I installed open SSH first-that may have been the problem.

    EDIT: It didn't restore the Winterboard Theme she was using. but it DID add boss preferences, Cycorder, terminal, etc.
     

Share This Page