AptBackup Re-Restore

Discussion in 'Jailbreaks and iOS Hacks' started by KnightRiderX, Jun 24, 2009.

  1. KnightRiderX macrumors newbie

    Joined:
    Jun 24, 2009
    #1
    My problem starts like this. I had previously jailbroken my iPhone 3G with redsn0w 0.7.1 and after jailbreaking, I realized that there was a long halt when exiting an app. During that time, I had performed a Restore from my last Backup on FW 2.2.1. I realized that AptBackup was only bringing back my repositories but not my packages and that's when I found out that AptBackup was not fully compatible with 3.0.

    Since then I've heard that AptBackup is now compatible to 3.0 and so I figured it was finally time to restore my iPhone and fix the problem I had. I do the restore and jailbreak it and everything goes on without a hitch. Now I am trying to Restore my last Backup from 2.2.1 again and it won't let me because the Backup from AptBackup has already been restored on my iPhone.

    So my question lies: Is there a way to trick AptBackup into thinking that I haven't restored the Backup yet?
     
  2. KnightRiderX thread starter macrumors newbie

    Joined:
    Jun 24, 2009
    #2
    Does anybody have an idea on how to fix this? Plz help.
     
  3. Enigmafan420 macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #3
    I apologize if this doesn't answer your question, but I think it might.

    For me, the ONLY time I have ever got Aptbackup to work is when it was the FIRST item I installed from Cydia, or had pwnage install it using the expert settings to select which files to install.

    It is my experience that if you do ANYTHING (including downloading ANY app except aptbackup from Cydia) then Aptbackup doesn't recognize you are trying to restore.

    So-what I would do is restore your custom IPSW again, and download Apt backup before ANYTHING (including any Cydia updates!) and it SHOULD restore, at least that is how it has worked for me.
     
  4. KnightRiderX thread starter macrumors newbie

    Joined:
    Jun 24, 2009
    #4
    I am soo hoping that I don't have to go through the whole process of backing up, restoring, and jailbreaking. Also Enigmafan420, I thank you and appreciate your attempt but I don't think that will do it because on my first 3.0 jailbreak, I downloaded SBSettings after downloading AptBackup and when I restored using AptBackup, it worked just fine (apart from it not installing my packages).

    If anybody has anymore ideas or fixes, plz don't hesitate.

    P.S.: One Question: Does AptBackup now install all of your packages?
     

Share This Page