Archive Utility problems

lisbakke

macrumors newbie
Original poster
Jul 29, 2005
23
0
I zipped up about 3 gigs into a 2.24 gig zip file. I did it with stuffit deluxe, and I had no problems opening it. Then, I sent the file over the network to my roomate and reformatted/reinstalled OS X Tiger, then d/l'd the file back from my roomate.

Now, it won't open! I'm just using the standard OS X BOM ArchiveHelper... it gets like 75% done and says:

Unable to unarchive "filename.zip" into "Desktop". (Error 1 - Operation not permitted.)

:mad:

Any ideas?

Thanks in advance.
 

stridey

macrumors 65816
Jan 21, 2005
1,136
0
Massachusetts, Connecticut
lisbakke said:
I zipped up about 3 gigs into a 2.24 gig zip file. I did it with stuffit deluxe, and I had no problems opening it. Then, I sent the file over the network to my roomate and reformatted/reinstalled OS X Tiger, then d/l'd the file back from my roomate.

Now, it won't open! I'm just using the standard OS X BOM ArchiveHelper... it gets like 75% done and says:

Unable to unarchive "filename.zip" into "Desktop". (Error 1 - Operation not permitted.)

:mad:

Any ideas?

Thanks in advance.
Well, try unzipping it with Stuffit (right click on the .zip, or control-click if you prefer, and select Stuffit from Open With...). See if that still works. I don't really expect it to, but it's worth a shot. :D
 
Comment

superbovine

macrumors 68030
Nov 7, 2003
2,872
0
open up terminal in the utility directory and copy the into you home directory.

from terminal type:
unzip filename.zip -d directory name
for example if your file name was "a.zip" and you wanted it in a directory named "a" then you would type:

Code:
superbovine:cow ~/$ unzip a.zip -d a
Archive:  a.zip
  inflating: a/deviance.nfo          
  inflating: a/Trainer.exe
 
Comment

ledbetter

macrumors newbie
Feb 5, 2008
1
0
i am also having the same problem and your advice did not work for me. here is the detail that i'm receiving in terminal:

todd-grimes-computer:~ toddgrimes$ unzip reasonrefill.zip -d reasonrefill
Archive: reasonrefill.zip
End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.
unzip: cannot find zipfile directory in one of reasonrefill.zip or
reasonrefill.zip.zip, and cannot find reasonrefill.zip.ZIP, period.
todd-grimes-computer:~ toddgrimes$

i zipped up all of my reason refills from my old computer using the default BOMArchiveHelper app to no avail. i have also tried using StuffItExpander and receive the following error code:

The Archive may be damaged (Error #17537)

Thanks in advance for any help!
 
Comment

iCeFuSiOn

macrumors 6502a
Jul 18, 2007
511
0
Are you able to open this file from any other computer? It almost sounds like it was corrupted somehow.
 
Comment

kblessinggr

macrumors member
Mar 15, 2008
47
0
Grand Rapids, Mi
I ran into this problem too, and I fixed it by using the terminal (like someone mentioned above)

Apparently the Archive Utility seems incapable of asking you for a password, instead it just errors out. So if a zip is password protected, you either gota use an application that was developed by someone with brains, or use the terminal.
 
Comment

KA9Q

macrumors newbie
Jan 15, 2009
6
0
The problem is with archive entries without a directory prefix

I ran into this problem tonight and tracked it down to Archive Utility. If you ask it to extract a zip file containing a member with a name of the form "foo" rather than "dirname/foo", you will get the message "Error 1 - Operation not permitted". This is true even if you have write permission on the current directory. Unzip from the command line doesn't have this problem, so that's a workaround.

While it's bad form for an archive to extract into the current directory, polluting whatever may already be there, it's also bad form for a program to bomb out with such a cryptic and misleading error message. It should tell you what's going on and ask you to approve the extraction or have you specify another folder.
 
Comment

klexxer

macrumors newbie
Jan 18, 2009
1
0
Error-1 Unzip from Command line ?

KA9Q - what does "Unzip from the command line" mean
I suppose you are referring to Terminal here but am a novice in that department. Could you/anyone who successfully used this hint to unzip the "error 1" files comment on this, please. Thanks
 
Comment

ANCTrumors

macrumors newbie
Nov 16, 2009
3
0
Some help on this topic would be greatly appreciated. I restored my account, whilst in the process I changed my home name. Now I cannot access the file at all. It still comes up with the error message 'error 1 - operation not permitted.

I attempted what I know in terminal 'unzip /documents/archive.zip' but as ledbetter showed

todd-grimes-computer:~ toddgrimes$ unzip reasonrefill.zip -d reasonrefill
Archive: reasonrefill.zip
End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.
unzip: cannot find zipfile directory in one of reasonrefill.zip or
reasonrefill.zip.zip, and cannot find reasonrefill.zip.ZIP, period.
todd-grimes-computer:~ toddgrimes$

came up, naturally the account name was different.

do we need to open the file through terminal another way?

Please can someone help with this?

Thanks
 
Comment

calibrate

macrumors newbie
Oct 22, 2009
2
0
Really Ugly Workaround

I'm having the same problem. I think the cause is that the file is missing its end. (I have a file that claimed to be 800 megabytes, but I only downloaded 500, even though I got no error message).

I did find that I could get most of the file from the command line. When opening the file, the Archive Utility will expand everything that IS present, then when it discovers the file is not complete, it DELETES it again. :-(

To save the partial file is ugly, and requires both the command line, and Apple Archive Utility

open a terminal windows (Find terminal under applications)
Type the following (lines starting with # are directions, don't type them!)

cd /tmp
# Type open, and the full path and name of your file
# like open /Users/john/Desktop/myfile.zip
open path-to-your-file/filename.zip

# BEFORE THE ARCHIVE UTILITY FINISHES:
# Click on the terminal window and type
ls -al

# Look for a file named with a name random name (like .BAH2NMxl),
# it should have the current date and time on it. This is a temporary file
# that is created while unarchiving the file.
# type cd (the name of the temporary file)

cd TEMPFILENAMEGOESHERE

# this will keep archiver from deleting the parts of the file that it DOES have
# When the archiver finishes, type
open .

__________________________
You now have the pieces of the file that were in the archive.

I don't promise this will work for you, or that this is the best method, but it got me most of what I needed.
 
Comment

ANCTrumors

macrumors newbie
Nov 16, 2009
3
0
cd /tmp
# Type open, and the full path and name of your file
# like open /Users/john/Desktop/myfile.zip
open path-to-your-file/filename.zip

# BEFORE THE ARCHIVE UTILITY FINISHES:
# Click on the terminal window and type
ls -al

# Look for a file named with a name random name (like .BAH2NMxl),
# it should have the current date and time on it. This is a temporary file
# that is created while unarchiving the file.
# type cd (the name of the temporary file)

cd TEMPFILENAMEGOESHERE

# this will keep archiver from deleting the parts of the file that it DOES have
# When the archiver finishes, type
open .
Hey mate, hopefully you can get back to me on this.

I tried to follow your instructions up to the point where you type 'ls -al'. How far into the extraction process do I need to wait until I type this?

Also, where might I find the temporary file? the .zip file takes up a ton of space after extracting like it should, but then I am unable to find it anywhere!

Thanks

my email address is anct@rocketmail.com. Would be really great to hear back from you!

Adam
 
Comment

alessi

macrumors newbie
Oct 29, 2010
1
0
Archive Utility

When trying to open an email attachment a window "Unarchiving "attachments _29_10_2010.zip appeared and got stuck. I cannot cancel or close the application. What can I do? I cannot log out. Help.
 
Comment

michael1willson

macrumors newbie
Mar 18, 2011
1
0
Same problem here to me it seems that it has to be a problem with the Archive utility because if I re-download the file a few times eventually it will unzip it. I have had the error with several different files including files from apple.com. Definitely annoying.

Unable to unarchive "filename.zip" into "Downloads". (Error 1 - Operation not permitted.)
 
Comment

wpardy

macrumors newbie
Mar 19, 2011
1
0
Archive Utility probems

I am also having some problems with the Archive Utility. Every time I try to use the utility, it becomes non-responsive and I need to force quit. So, I first encountered the problem this morning. I have tried to download new software that perform similar tasks but they require the Archive Utility to instal! Does anyone have any advice?
 
Comment

ramflyus

macrumors newbie
Jun 4, 2009
1
0
having the same problem (Error 1 - Operational not permitted) whenn double click to unzipped the file.

But able to open the file with 'open with stuffit Expander.
 
Comment

RJH3

macrumors newbie
Oct 8, 2011
1
0
This is really REALLY frustrating!

hello all

I have a slightly different problem with (the previously blogged about and absolutley evil) Archive Utility and getting stuck on on 75% opening a .zip

I used Microsoft PowerPoint and exported/compressed my pptx file. I then tried to open it. It seems to have frozen and hasn't done anything else for 19 hours. There is not a red close button in the right-hand corner and cancel does not work.

I have tried going on the side-bar and clicking on force quit, but it refuses to quit. I have tried to shut the computer down and also restart it but because (the previously blogged about and absolutley evil) Archive Utility box is open, it overrides the command and the computer stays open.

In my frustration I deleated the pptx file and removed it from my trash. This did not work either. I am considering letting the battery run flat and hoping that it forces my macbook to close.

Do you have any comments or suggestions? I would be SO SO SO greatful of any advice.

<3
 
Comment

AndrewMeyerson

macrumors newbie
Sep 22, 2012
1
0
New York
Recommended Fix for the Error 1

I had a 4.78GB zip file that had photos and video from an event that I shot and to my horror it wouldn't open after compression, instead giving me an "Error 1 - Operation not permitted" response.

I tried Stuffit Expander and it said the .zip file was corrupt and then I turned to the App Store and found "The Archive Browser" for $4.

It's a great utility that allows you to browse inside a zipped file and then only extract the individual files that you want.

Verdict: It worked perfectly and totally saved my files. I was able to extract all of them without a problem. Give it a shot, it's well worth the money.

Download it here: <http://itunes.apple.com/us/app/the-archive-browser/id510232205?mt=12>.
 
Comment

jspringate

macrumors newbie
Sep 27, 2007
1
0
Many thanks Andrew! I also had the same problem and downloaded The archive Browser and it solved the problem. I highly recommend it! Its not breaking the bank and worth a try!
 
Last edited:
Comment

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.