Are Arris modems known to dislike Apple?

Discussion in 'Mac Basics and Help' started by Rantipole, Jun 17, 2012.

  1. Rantipole macrumors 6502


    May 24, 2004
    I've just moved and had Comcast install the phone/wi-fi router. (At my old place, I had a linksys netgear wi-fi router which worked fine.)

    Now, my Windoze netbooks stays connected perfectly to the Arris wi-fi. But neither my iPhone, iPad ( both OS5) nor Mac (Snow Leopard still) can stay connected. I have to reset them.

    I'd love to put the blame on Comcast/Arris, but there is the solid connection for the netbook staring me in the face. And when I called Comcast for help, that is their position as well... "you have a connection, so it is not a modem issue." Is this an Apple issue?

    It is the Arris TG862g/ct if that makes a difference. It handles the landline phone, wi-fi, and could handle ethernet lines as well.

    Thoughts? Thanks.
  2. teelok macrumors newbie

    Jun 19, 2012
    ARRIS to IPAD Problem?

    I seem to be having the same problem connecting the IPAD2 to the ARRIS TG862G/CT modem/router. I've contacted COMCAST as well as APPLE and came up empty. Since the modem/router was obtained from COMCAST, ARRIS doesn't appear to want to talk with me directly. Have you had any success?
  3. boatbuilder macrumors newbie

    Jun 20, 2012
    I just installed one too and it seems to work fine except that when I open windows 7 on my imac using Parallels I get an I.P. address conflict pop up message and lose my wifi connection on the imac.

  4. Rantipole thread starter macrumors 6502


    May 24, 2004
    After further research, it appears these "all-in-one" routers are trouble. Mine is currently working again, but apparently the wi-fi element is frequently a problem. I've haven't needed to try yet, but I heard pressing the reset button for a full 60 seconds may help.

    If I continue to have problems, I think the best solution is to get a separate wi-fi router.
  5. boatbuilder macrumors newbie

    Jun 20, 2012
    I called Parallels Support and they quickly fixed it. They told me to open Parallels, click on Devices at the top of the screen, click on Network 1 and check Shared Network.

    seems to work ok now.
  6. teelok macrumors newbie

    Jun 19, 2012
    ARRIS to IPAD Problem?

    I seem to have found the solution to my problem of not being able to connect an IPAD2 to the TG862G/CT. When I initially tried to connect using the supplied key found on the bottom of the Modem/Router, the key wasn't accepted. I then made up a new key and tried it. The new key worked. Why the provided key wouldn't work, I don't have a clue. Note, to clear the old key in the IPAD, you need to enter GENERAL|RESET|RESET NETWORK SETTINGS.
  7. weespeed macrumors 6502

    Jul 9, 2010
    This was my solution as well.
    Seems all the windows PC's in the house would connect with that 20 digit password, but none of the Apple devices would. 4 iphones, 2 ipads, and a Macbook air. But changing the wifi password solved it all.

    I'm thinking the password is just too long for the Apple devices. MAybe it wasn't programmed to take that crazy factory password.
  8. larrylaffer macrumors 6502a


    Aug 1, 2009
    Los Angeles
    I used to have an AT&T 2Wire router for my DSL. A fascinating thing used to happen with this modem. If a PC was connected by itself, it worked fine. If a Mac was connected by itself, it worked fine. If two PCs or two Macs were connected, it worked fine.

    If however a Mac and a PC tried to be on at the same time, the modem would reboot every few minutes. AT&T didn't believe me.

    Moral: Buy an AirPort or a used Linksys. Yes, it sucks that you have to spend more money, but in my experience the ISP will be just about as unhelpful as possible.
  9. Rantipole thread starter macrumors 6502


    May 24, 2004
    I'm all for the security that comes with random letters and numbers, but those passwords are absurdly and unnecessarily long.

    I've found another "fix" elsewhere. This fix worked only for a week, the first time I tried it, then has been working uninterrupted for about a month now. Press the reset button, but hold it in for at least 60 seconds before releasing it. This resets everything, so if you have adjusted the password, you'll have to do it again.
  10. jblagden, Apr 26, 2014
    Last edited: Apr 28, 2014

    jblagden macrumors 65816


    Aug 16, 2013
    Airport Extreme

    A great way to avoid this is to use your own wireless router instead of using the modem's built-in router. I use an Airport Extreme which is connected to the Arris modem. Besides, this reduces the modem to just that, a modem. Also, with an Airport Extreme, you can plug in printers and hard drives so you can share them across the network.
  11. withicdex, Sep 6, 2015
    Last edited: Sep 6, 2015

    withicdex macrumors newbie


    Sep 6, 2015
    This is a very old thread but I had a very similar issue in 2015. My Arris dg1670a router/modem worked great with all my devices. At this point in time "all my devices" did not include anything Apple. It was 2 Android phones, 1 Windows Desktop, and 1 Android Tablet. I wasn't an Apple guy---yet. This set up worked for 9 months and router/modem worked quite well! Now fast forward to a few days ago. I bring home a beautiful MacBook Pro and it malfunctions on the same network.

    This was the problem. The Macbook connected fine. The problem was that when it went to sleep after 30 minutes or so, after waking it up, it would look like it was connected to my network but I couldn't access the internet. The only way to "fix it" was to turn Wifi off and on again. EVERY TIME the computer went to sleep for 30min or more.

    TL;DR: Try going into the Arris Modem/Router Wireless setup. The login ip is by default Default username is "admin" and default password is "password". (Please change the password by the way). Click on the 2.4ghz and Wireless 5ghz tabs in your router setup and do the following for each. Under "Security Mode," CHANGE both the 2.5ghz and 5ghz WiFi networks to WPA/WPA-2-PSK (TKIP/AES) (Most Compatible). The factory settings are marked WPA-2-PSK (AES)(Recommended), which should be really marked (Recommended for tearing your hair out with a Mac).

    Hopefully this will sort your problems. It took me ages with support with both Apple and my Cable company, trips to the Apple store, constant Google searches etc. But the last guy at Apple support clued me into this security mode change.

    Also the closest description to my exact problem is here: . However, I don't have Time Warner so I couldn't actually post under that thread.
  12. withicdex macrumors newbie


    Sep 6, 2015
    Scratch that... I'm still having problems.. maybe the above will work for you though :(
  13. riviera74 macrumors member

    Jul 18, 2015
    Fort Myers FL
    You might want to consider upgrading the firmware too from Arris's website.
  14. painless macrumors newbie

    Sep 16, 2015
    One thing you might try is to disable 5ghz. Most apple products can't use wifi N at 5ghz, forcing it to operate in G mode.

    I work at a cable company, and we use these modems. Wifi G is HORRIBLE on these modems.

    Best bet? Spend the 40 bucks for a small Cisco or Netgear broadband router, call the cable company to put the modem in bridge mode, and relax and enjoy your new peace of mind.

    BTW: Don't bother buying a new motorola cable modem. Arris bought them 2 years ago.
  15. Fishrrman macrumors G5


    Feb 20, 2009
    You are a Comcast user using the Arris TG862g/ct residential gateway?

    I don't have Comcast yet. I'm currently still using Frontier (formerly ATT in my state) Uverse equipment that also uses a residential gateway setup (that is, a combined modem and router/wifi).

    In my case, the wifi from the gateway was slow.

    My solution:

    Turn the gateway's wifi OFF, and plug an Apple Airport Extreme into one of the ethernet ports.

    I then setup the APEx in "bridge mode" (no NAT function).

    - residential gateway is still providing NAT but wifi is OFF.
    - APEx is now the Wifi access point but doesn't do NAT (so as not to end up in a "double NAT" situation that can cause problems).

    Seems to work quite well this way.

    The APEx I'm using is an older (flat) version, but I see you can get the latest version from Apple's refurb page for $129.
  16. phrehdd macrumors 68040


    Oct 25, 2008
    Yes always a good idea to change the defaults on a router or modem-router. Just make sure you keep both pieces of info for reset or issues that occur later.

    If you find that your Apple device has issues re-connecting and you are sure nothing has changed on the modem-router or router, you may want to delete the entry on your device entirely and try again to add it.

    Presently, I am visiting someone with a modem router (DSL line) and it is 802.11b. Talk about no range and slow as slow can be. However, my laptop and iPhone (and their phones and iPad) all seem to connect when they are in range. Sadly, their neighbors are using for 2.4 too and also nearly all are channel 6. I am hoping to get the channel changed to 1 or 11 to help with the noise/interruption issue until I get them set up with a new router and possibly over to cable services.

    As for modem-routers, I too don't advocate them and especially if provided by a provider. However, purchasing a higher end cable modem-router is not a bad option under some instances. They are expensive but it really is two high end devices in one and has almost the flexibility of buying separates. Netgear C7000 is perhaps the top of the line offering best of breed DOCSIS 3 for the modem side (not all are created equal) and a 3 internal antennae AC router that you can access and define your parameters. I'll still continue with separates but if I had to have a single "box" it would be that particular modem-router for cable.

Share This Page