Are you using a high-precision / gaming mouse? Erratic pointer jumping issue

Discussion in 'macOS' started by Dae, Apr 8, 2010.

  1. Dae macrumors regular

    Dae

    Joined:
    Apr 30, 2009
    #1
    Hi,
    I would like to draw some attention to the mouse movement bug of Mac OS X. It affects only the users of high-precision / gaming mouses. I believe that most people don't notice it.

    Please check the video:
    [​IMG]
    (the link will open in a new window; not sure how to embed properly, sorry!)

    — If you experience similar pointer behavior, please post your mouse product name and manufacturer, and OS X version you use.

    — If your mouse is in the list below, please tell me: do you notice mouse behavior as described in the video?


    The list of affected mouses:
    • Logitech G5
    • Logitech RX1000
    • Razer DeathAdder 3G
    • Logitech G3
    • Logitech G9x
    • Razer DeathAdder
    • Razer Copperhead
    • Razer Lachesis
    • Razer Salmosa
    • Saitek GM3200
    • Razer ProClick
    • Logitech MX510
    • Logitech G500

    I gather information on the bug in my blog: http://dae.cyberic.eu/blog/mouse-cursor-skipping-jumping-bug-on-mac-os-x

    I have already submitted it to Apple.

    Thanks for attention!
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    You need a good mousing surface, as high-DPI mouse picks up surface imperfections and user twitch.
     
  3. Dae thread starter macrumors regular

    Dae

    Joined:
    Apr 30, 2009
    #3
    I use a Steelseries mouse pad, I tried on several others with no difference at all.

    And the problem does not appear on Windows XP/Vista/7 with or without appropriate mouse drivers from the manufacturer.

    So it's a software bug of Mac OS X and apparently it existed since 10.4 yet remained unnoticed.
     
  4. splatt macrumors member

    Joined:
    Jun 18, 2009
    #4
    It does it for me, but far worse than that. The mouse will teleport 10" across my 27" imac screen. This happens with both the magic mouse and a logitech mx laser mouse. It doesn't happen at all when I boot into windows via bootcamp.
     
  5. Crav macrumors newbie

    Joined:
    Apr 19, 2010
    #5
    Logitech MX-1000 mouse is jumping

    I'm a graphic designer, and I think I'm going to go crazy if my mouse doesn't stop jumping.

    Using a Logitech MX-1000 on G5 tower PPC 10.5

    I have never had this problem before on my G5 PPC 10.5, until I completely wiped the system last week to re-install Leopard.
    I had used this mouse on this system for 1.5 years with no problem.

    After the clean Mac OS X install, the jumping didn't start until I installed the Logitech driver, which I know was a newer driver.
    I would go back and find the older driver I used, except as I went to research this problem, I noticed people 2 years ago were complaining about this on Macs. So I don't know what to do.

    I'm going to plug my MX-1100 in and see if the problem continues, but I'm going to guess YES:mad:
     
  6. J the Ninja macrumors 68000

    Joined:
    Jul 14, 2008
    #6
    I just tried painting a line with my MX1100 in Pixelmator, and it never jumped. The line was a straight as a I could move my hand. Now, I should preface, I use Steermouse (so should you, it rocks). I have the acceleration in Steermouse set to be the same as the system driver, however. A couple notes about these high-precision mice:

    1. Use a pad. Any pad is better than nothing. And personally, I'd avoid pads with images on them. A plain, dark, textured surface is best.

    2. You should turn the DPI setting to max for normal usage, and adjust the sensitivity in software to taste. The lower settings are only for when you need to temporarily slow down your cursor. (Aiming a sniper rifle in a game, delicate painting in Photoshop, adjusting those tiny sliders in FCP, etc). Remember, if you set your sensitivity multiplier > 1, the system will have to interpolate your cursor position, which can worsen issues like cursor jumping. It literally doesn't know which one of several pixels your cursor should actually be on, so it just guesses.
     
  7. ToastyX macrumors regular

    Joined:
    Oct 4, 2005
    #7
    Mac OS X can't handle 500 Hz and 1000 Hz mice properly.

    Actually, it can't handle mouse movements properly with any mouse, but the problem is much worse with high sample rate mice.

    The MX510 and MX518 should not be affected any more than a standard mouse since they run at 125 Hz.

    The MX1000 and MX1100 are not high sample rate mice either.

    For the Logitech G5 (both 500 Hz and 1000 Hz versions), Steermouse works around the problem by setting the mouse to 125 Hz. I'm not sure what other mice Steermouse has workarounds for.

    The Razer DeathAdder can be set to 125 Hz using the Windows driver, and the setting is stored in the mouse itself.
     
  8. petsk macrumors 6502

    petsk

    Joined:
    Oct 13, 2009
    Location:
    Northern Europe
    #8
    I have a high-precision Razer Mamba mouse and it's affected by this movement bug, tested in Photoshop like the video shows.

    - Razer Mamba, connected with cable (not wireless)
    - OSX 10.6.3
     
  9. H00513R macrumors 6502a

    H00513R

    Joined:
    Mar 12, 2010
    Location:
    Indiana
    #9
    Have you checked your polling rate? That makes a big difference. Just a suggestion.
     
  10. petsk macrumors 6502

    petsk

    Joined:
    Oct 13, 2009
    Location:
    Northern Europe
    #10
    I haven't bothered to boot up Windows yet, but I will try lowering the poll rate later on, I know it's set to a high value right now.
     
  11. Dae thread starter macrumors regular

    Dae

    Joined:
    Apr 30, 2009
    #11
    This is a news for me, thank you.
     
  12. Dae thread starter macrumors regular

    Dae

    Joined:
    Apr 30, 2009
    #12
    This did not work for me with blue G5 + latest SteerMouse running on 10.6!
     
  13. RedReplicant macrumors 6502a

    Joined:
    Mar 31, 2010
    #13
    I had a Logitech G3, it did this and made the mouse unusable.
     
  14. ToastyX macrumors regular

    Joined:
    Oct 4, 2005
    #14
    I tested both the silver (500 Hz) and the blue (1000 Hz) versions with Steermouse a long time ago. It's possible there is more than one revision of the blue version. Are you able to assign the DPI buttons? If not, then SteerMouse doesn't support your revision. Otherwise, it should work, but maybe something changed. I will test again some time soon.
     
  15. ToastyX macrumors regular

    Joined:
    Oct 4, 2005
    #15
    I just tested both versions of the G5 with the latest version of SteerMouse, and you're right; it doesn't work. I clearly remember it working before, so I tried older versions and found the workaround was removed in 4.0 for some reason. It works properly with 3.9, which isn't available for download anymore, so here is a copy: http://www.toastyx.net/SteerMouse3.9.dmg

    The right side is the blue version of the G5 with SteerMouse 3.9:
    [​IMG]
     
  16. lulaz macrumors newbie

    Joined:
    Sep 12, 2010
    #16
    I have the same issue with my Logitech G9 (not G9x) on MacOS 10.6.4. I tried Steermouse 3.9 and 4.0.2 (the latest) but it didn't help. Wonder when this will be fixed ... ;(
     

Share This Page