Areca 1210ML and Beep on Startup

Discussion in 'Mac Pro' started by oz1, Nov 16, 2009.

  1. oz1 macrumors member

    Joined:
    Mar 11, 2009
    #1
    I have just installed an ARECA 1210ML external RAID controller in an early 2008 octocore Mac Pro. Everything seems to be working fine.

    However, when I press the power button to switch on the Mac, there is a immediate loud single beep. I am using refit & the beep happens before the list of OS's appears.

    There is a system setting in the ARECA config web interface that allows me to
    disable the system beeper but it doesn't seem to stop the beep.

    Suggestions gratefully received.
     
  2. gugucom macrumors 68020

    gugucom

    Joined:
    May 21, 2009
    Location:
    Munich, Germany
    #2
    It is a feature you cannot stop. All you can do is fit a solid layer of film over the speaker hole on the card. The speaker is a small cylindrical plastic part with a center hole.
     
  3. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #3
    It's normal, and can't be stopped.

    The reason is, the "beep" sounds the moment the card obtains power. The firmware hasn't yet loaded to determine/do anything, and why the setting won't turn that particular beep off. Once the firmware has loaded, then the the firmware will disable the alarm if you've set it to do so.

    gugucom's suggestion is the only thing you can do short of desoldering it from the card.
     
  4. oz1 thread starter macrumors member

    Joined:
    Mar 11, 2009
    #4
    Thanks guys. I thought I'd done something wrong.

    Incidentally, the ARECA has let me recover 3 of the 4 1TB drives that couldn't be recognised after being connected to a Rocketraid 2644. Thanks to Nanofrog for pointing me in this direction.
     
  5. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #5
    :cool: NP. :)

    BTW, what's up with the 4th disk?
    Totally unusable (i.e. start over and still won't show as available)?
     
  6. oz1 thread starter macrumors member

    Joined:
    Mar 11, 2009
    #6
    I'd say totally unuseable. Tried it in the external storage on its own & even the ARECA wouldn't recognise it. Tried it in one of the Mac bays - still no joy. Even tried it in an external USB drive case on a PC with the same result.

    At least I got my other 3 back.
     
  7. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #7
    Ok. Try running SMART, check for bad blocks, and the drive's firmware revision (just in case it's an older version than what functions with the drive).

    To do this, you would want to attempt setting the drive as a Pass Through. If that doesn't work, then attach it to the logic board (less picky with drive firmware).

    Depending on the results, you may have to reflash (contact the drive maker and Areca for the firmware, as I don't know the drive's make/model), remap, or RMA the drive. But I'm thinking the firmware may need to be flashed, assuming it was working previously (was damaged by the other card).

    Please post the results. :)
     
  8. oz1 thread starter macrumors member

    Joined:
    Mar 11, 2009
    #8
    Disk is a Samsung HD103UJ 1 TB.

    So far no luck. I tried in the external storage connected to the ARECA with all the other drives in the storage disconnected. All I got was a lot of clicking
    & the drive was not recognised so I couldn't run SMART. Haven't tried it in the MAC bay yet as I'm a bit concerned that I may do some damage. Will try a pass through next.
     
  9. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #9
    So you tried to connect the drive directly to a PC (no RAID card at all)?

    The clicking sound is a strong sign of a dead drive btw. And assuming the method of attempted access is as described above, you need to RMA it to Samsung. They don't seem to be the best brand of drives, and that model is a consumer unit. When using RAID (especially with a RAID card), you really should be running enterprise models.

    There's differences in the firmware. Namely the recovery timings (consumer = 0,0, and enterprise = 7,0; numbers are seconds to attempt recovery). The reason is the OS handles the recovery when the drive is connected to the board (also true for software based RAID). But with a proper hardware controller, it's up to the card to take over that function.

    Then there's the added sensors and improved specifications to consider as well. They're also built for 24/7 operation in high vibration and temperature environments.

    Something to seriously consider. ;)
     
  10. oz1 thread starter macrumors member

    Joined:
    Mar 11, 2009
    #10
    Yes, I tried it in a PC with no success. It went back for a refund/replacement this afternoon.

    Any suggestions re 1 TB enterprise class HDDs? I've been using Seagate Barracuda consumer grade drives for years in PCs including in RAID arrays without any problems. I recently tried WD Caviar Blacks for a change but had 2 out of 4 DOA so that put me off the brand. The other Samsung HD103UJ models I have (5) have been OK so far but I'm starting to get very fussy about backing up data.

    Thanks for your help.
     
  11. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #11
    As I've mentioned before, RAID cards are picky with drives (SAS cards are even worse about it), and the recovery timings matter. Consumer drives on Areca's tend to be too unstable to use. Works, drop-out, get back, another drops out,... Wash, rinse, repeat. It's a major PITA.

    I'd say go for the WD RE3 1TB units (WD1002FBYS), as they're on the HDD Compatibility List. And I've not had any issues with the RE3's so far. You should be able to find them for ~$160USD each. Not as inexpensive as the consumer models, but they're built for what you're doing, and will be much more stable and reliable IMO. Definitely worth the additional funds to avoid the headaches alone of an unstable array.

    Seagate's enterprise line is the ES.2 models, but the last ones (same time the 1.5TB consumer drive fiasco) had firmware problems as well, known as "The Boot of Death". As a result, I've lost faith in Seagate to make a problem free drive, even in the enterprise world.
     
  12. oz1 thread starter macrumors member

    Joined:
    Mar 11, 2009
    #12
    Thanks Nanofrog. I'll look into the RE3s. Looks like I can get them here for about $190AUD.
     
  13. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #13
    They're good drives IMO. They work better on the SAS cards than the Seagate ES.2's as well (though enterprise, are less stable given there is still the tendency for them to drop out on the Areca SAS card I tested with; ARC-1680ix12). I've not had to rebuild at all, but mine are attached to a SATA card (ARC-1231ML).

    I also forgot you're in Australia. Brain fart. :eek: That's a bit more expensive than the lowest they can be had here, but it's not horrible, as $190AUD is ~$174USD (some sites are that high here). As I understand it, things can get rather bad there, before taxes. Then there's the GST, and in some cases a tech tax on top of that (by specific location :confused:). :eek: Yikes. :(
     

Share This Page