Areca Raid Gurus...Please help with Raid 5 setup

Discussion in 'Mac Pro' started by mluters, Sep 9, 2012.

  1. mluters macrumors member

    Joined:
    Jan 25, 2010
    #1
    My Setup:

    - 5.1 MP with 3.4 ghz hex core/24gb 1333mhz ram/ML 10.8.1
    - Areca 1882-ix-12 firmware 1.51/Battery Backup Unit/4gb Cache
    - Boot Drive - Pair of 240gb Intel 520 SSD in raid 0 connected to Areca card internal port SFF-8087
    - Data Drives - 8 WD RE4 2tb drives in 14tb raid 5 with 128k stripe (all new drives with latest B01 firmware)
    - Enclosure - Cineraid CR-T08E enclosure (http://www.cineraid.com/products/editpro_x_t08e.htm) and connected via 2 SFF-8088 mini-sas ports
    - Mini-sas adapter - ADP-8873-2X (http://www.cs-electronics.com/mini-sas_adapters.htm) to allow second mini-sas cable to be attached

    My Problem:

    When testing 8 drive raid 5 with AJA system test or Blackmagic I get reads of 630mbs and writes of 1120mbs...shouldn't the reads be much better in a 8 drive Raid 5 setup? Here is a comparable setup: http://www.arecaus.com/areca_tests_1882x_mac_8_st33000650ns.htm I realize those test drives were 6Gb/s SATA and mine are 3Gb/s sata but I still thought I should get much better read speeds? Before I switched to the Cineraid enclosure, I had a internal 6 drive raid 5 setup (same WD drives and Areca card) with read/writes of approx 750/750 mbs...which seems appropriate for that setup. So why are my 8 drive raid 5 read numbers so SLOW?

    What I've tried:

    1. Tested same 8 drive setup in Raid 0 and saw approx 1350/1350 read/writes...so the system is capable of very fast read/writes.
    2. I have tried a variety of different settings on the Areca card and nothing seems to make much difference.
    3. Switched out cables.
    4. Switched ports on the card.
    5. Switched ports on the enclosure.
    6. Contacted Cineraid and Areca tech support...still working with both to see if they have any other solutions.

    Any thoughts to whats leading to the slow read numbers in my raid 5 setup...I don't think it's a problem with the hard drives because the raid 0 numbers are right where they should be and the raid 5 writes are where they should be, it's only the raid 5 reads that are SLOW.

    Thanks in advance and sorry for the long post.
     
  2. DJenkins macrumors 6502

    DJenkins

    Joined:
    Apr 22, 2012
    Location:
    Sydney, Australia
    #2
    I have the Areca 1213-4i in raid 5, 4 x 2TB drives. It takes a LONG time to get up to top speed in the benchmarks.

    Blackmagic test only has 5GB transfer as max, I end up getting a very weighted result with well over 500MB/s write but under 300MB/s read.

    In AJA test I have to use the 16GB test size to get more even results... by the end of the test it ends up around 390MB/s both read & write.

    I used to have an ATTO card which hit it's consistent speeds really fast, so my guess is the Areca cards in raid 5 just take a long time to get up to speed.

    I don't think the fact your drives are 3Gb/s matters, even with 8 drives you're still well within that limit.

    Probably didn't answer everything just sharing my experience with the Areca cards
     
  3. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #3
    I have Pegasus stuff, but set in RAID 0 it's a lot faster, enabling real time editing work. 5 is of course much safer though, and I run additional backups just in case. The drives in my Promise are Hitachi...Not sure what yours are?
     
  4. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #4
    Check your ports, as some of the drives might be using the same ports via the SAS Expander located on the Areca card (native port count is 8, anything greater is handled via the SAS Expander). Please note I mean both arrays, as this could happen if mechanical disks are sharing a port with SSD's (SAS Expander is a switch, which adds latency on top of drives that may be maxing out or exceeding a particular SAS ports on the card during simultaneous disk use <operate A, switch to B, ..., depending on what's next in the Queue>). Under such conditions, either set will be negatively affected with regard to throughputs.

    Couple of other things:
    1. Check your settings, as they can slow you down if they're not tweaked properly.
    2. That card isn't the fastest they've ever built in some aspects (rebuilds for example), but it should be faster than what you're seeing.
    3. Check it's compatibility with the CineRAID enclosure (both Areca and CineRAID's sites). May also come down to enclosure communications (not supported, but set to active, or supported but not set correctly).
     

Share This Page