Argh, libgd + PHP 5 + MySQL won't install!

Discussion in 'Mac Programming' started by wrldwzrd89, Jun 19, 2007.

  1. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #1
    Using several guides on the Internet to getting PHP and libgd to work together, I managed to get all the different libraries libgd uses to work, but when I try to do a make and make install after configuring PHP as follows:

    Code:
    ./configure --with-apxs=/usr/sbin/apxs --with-mysql=/usr/local/mysql --with-gd-dir=/usr/local --with-png-dir=/usr/local --with-jpeg-dir=/usr/local --with-freetype2-dir=/usr/local --with-xpm-dir=/usr/local --with-zlib-dir=/usr/local
    I get two error messages:
    1) When I run the test script it complains about not being able to find libmysql15.so. This file is in /usr/local/mysql/lib/ but the script is looking for it in /usr/local/mysql/lib/mysql/, which doesn't exist.
    2) When installing PEAR, I get a Trace/BPT trap error.
     
  2. wrldwzrd89 thread starter macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Finally fixed this... I had to create a symbolic link to get PHP to find the MySQL libraries. Dunno why it wants to look in /usr/local/mysql/lib/mysql instead of /usr/local/mysql/lib...
     
  3. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #3
    gd is included with MAMP, any particular reason you didn't use this (or XAMPP)?
     
  4. wrldwzrd89 thread starter macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    I did not know MAMP existed until you told me.
     
  5. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #5
    I can't even count how many times I compiled crap the hard way and then discovered these!
     

Share This Page