Arghhh! Mac OS and files messed up!

Discussion in 'macOS' started by ozone, Jun 28, 2006.

  1. ozone macrumors 6502


    Feb 18, 2004
    Ontario, Canada
    Hi... need some help. My Mac seems all messed up and I'm not sure why...:mad: Although I regularly use my tablet, I was prepping up my 17" G4 (Tiger OS) for a short business trip. I can't figure out what happened, but here's the sequence:

    1. Put the unit in sleep. It was plugged in.
    2. Stuck in the spare battery to recharge.
    3. Restarted - all seemed fine and battery started recharging.

    I mention this in case the swapping of the battery is important.

    I then fired up Virtual PC. I needed to transfer some updated files via VPC to a Windows only program I use. This is where it starts getting weird.

    1. VPC started, but said it couldn't access virtual network switching. The weird thing was the VPC started up immediately and resumed in Windows. I was pretty sure I had shut it down completely the last time I used it.
    2. I messed around, including dragging a mounted USB drive in the VPC window. Took it out when nothing was happening.
    3. I tried shutting VPC down; even force-quit seemed ineffective.
    4. Finally got VPC to close.
    5. Decided that the best would be to restart - except when I did, the computer got hung up. Just sat there with partial icons and text on the screen.
    6. Manually powered off.
    7. Powered on - now it gets weird. I tried entering my password, hit 'enter', but nothing would happen. No 'wrong password', no system start up, the initialization sequence just 'got stuck'. Had to manually power off.
    8. This happened 3 times. On the fourth time, I got lucky and the system got started.
    9. ... except my dock is 'reset', no applications I've put in the dock remain, and when I tried opening a PowerPoint presentation that I successfully opened 3 hours earlier, the file was said to be corrupted!

    What happened? Did I fry something? Is the OS mucked up? Arrghhh... is there an easy fix or do I have to reinstall everything?

  2. Queso macrumors G4

    Mar 4, 2006
    Looks like you have two issues here. Firstly, go into the Utilities folder and open the Disk Utility program. Select your hard disk and click on the Repair Permissions button. My guess is that the computer will report a number of issues and repair them.

    Secondly, the virtual switch networking in VPC was broken by a previous OSX update, but Microsoft released a patch to fix it. Try installing that and see whether it removes your error.
  3. ozone thread starter macrumors 6502


    Feb 18, 2004
    Ontario, Canada
    Thanks! I'll give it a shot and see what happens.

Share This Page