Artist picture missing on iphone.

Discussion in 'iOS 7' started by DaGrandMastah, Feb 27, 2014.

  1. DaGrandMastah macrumors 6502a

    Joined:
    Mar 19, 2011
    #1
    So I have a very odd scenario coming up on my iphone. I loaded up 2 new artists the other day (everything is set to sync automatically) and it loaded up the artwork for the artists perfectly fine. A couple of days later it disappeared and now it won't come back. I tried everything. I removed the artist from the iphone, resynced and nothing. The odd thing is, if I change the name of the artist and add an extra character at the end then it will sync WITH artwork...but as soon as I change it back to the actual artists name I lose the arwork again.

    Anyone hve any idea why it's doing this and what can be done to fix it?
     
  2. RemarkabLee macrumors 6502a

    Joined:
    Nov 14, 2007
    #2
    Sounds like an iTunes Library issue or the Album Artwork folder corruption?

    Personally I like to embed my artwork into the MP3/MP4 files themselves - http://dougscripts.com/itunes/scripts/ss.php?sp=embedart.

    You can try embedding the artwork for the problematic album, then rename it back to the correct name - it should stick then.

    UPDATE: You may want to use the Re-Embed script instead, for Mavericks compatibility.
     
  3. DaGrandMastah thread starter macrumors 6502a

    Joined:
    Mar 19, 2011
    #3
    But the problem isn't that the album artwork isn't working...it's that the artist isn't showing a picture. Once I go into the artist selection all of the albums show the artwork as they should.
     

Share This Page