Artists showing up under the wrong letter

Discussion in 'iOS 5 and earlier' started by Cygo, Oct 31, 2011.

  1. Cygo macrumors newbie

    Joined:
    Sep 25, 2008
    #1
    Hi All,

    Not sure if this is the right forum for this question, but here I go.

    Ever since updating to iOS5 my music on my phone is all out of wack.

    Artists that should be under M show up under O, or even show up twice.

    When I do a hard reset it fixes this temporarily. I even set up my phone as a new iPhone because I though my backup was corrupt...this is driving me crazy and I'm not sure what more to do.

    I'm hoping there is a fix to this or that ios5 is just buggy and this will be fixed soon.

    I'd post a picture but I'm writing this from my phone and could not figure out how.

    Any advice is appreciated.

    Thank
     
  2. livingonaprayer macrumors newbie

    Joined:
    Nov 8, 2011
    #2
    I'm having the exact same issue....my entire music library is messed up on my iphone 4, it's really annoying if you're looking for a specific song or artist. Also, it just drives me crazy because I like things organized.

    I called apple and they had me do a complete restore of the phone and a bunch of trouble shooting issues but it still went back to being out of order, I'm going to call again.

    The tech guy said he's never heard of this issue but I googled it and found a lot of people complaining of the problem so I have a hard time believing they haven't had people calling support about the issue.

    If anyone has a solution please post it !! Thanks
     
  3. PassMeAGuinness, Nov 8, 2011
    Last edited: Nov 8, 2011

    PassMeAGuinness macrumors member

    Joined:
    Oct 20, 2009
    Location:
    Miami, FL
    #3
    This actually happened to me as well, but I beleive I have fixed the problem.

    DISCLAIMER: Edit these fields at your own risk, as you may further complicate the sorting of your iTunes library.

    With that being said, here are the fields you need to look out for.

    Right click all songs, from ONE specific artist, and make sure the following screen looks like mine. In other words: Make sure there is NO album artist.
    [​IMG]

    Also, On this screen (and I think this is actually the culprit for sorting things its own way), make sure that only the NAME, ARTIST and ALBUM fields are filled in. Nothing else should any info on it, as that may change the sorting as well.
    [​IMG]

    I am not truly sure if this is the actual fix for sorting, but It worked for me, after trying countless things. My library is now exactly the way it should be.

    And again, do this at your own risk. :)

    EDIT: To the original post, I just re-read that when you reset the phone, it temporarily fixes the issue. Therefore, my post may not be what you are looking for. Perhaps, it is a buggy phone.
     
  4. peapody macrumors 68040

    peapody

    Joined:
    Oct 7, 2007
    Location:
    baltimore, md
    #4
    Been having this issue - I do have my album artists filled in for some artists for sorting purposes...a restore solved the problem temporarily but then now I am getting artists sorting incorrectly. Anyone know a fix??
     
  5. redsoxbaseball7 macrumors newbie

    Joined:
    Nov 30, 2011
    #5
    Solution

    Much easier than the earlier solution.

    Settings -> Music-> Group By Album Artist-> Off
     

Share This Page