Artwork is wrong on iPod Video

Discussion in 'iPod' started by Samelson03, Mar 1, 2011.

  1. Samelson03 macrumors 6502

    Joined:
    Mar 8, 2007
    #1
    In iTunes my artwork is all correct but on my iPod it's wrong. How exactly did this happen and how do I fix it?
     
  2. Schroedinger macrumors regular

    Schroedinger

    Joined:
    Feb 12, 2004
    Location:
    Baltimore, MD
    #2
    I've had similar problems if I have been changing songs frequently for a long period of time. I have found a restore solves the problem. It's almost like windows bitrot.
     
  3. Samelson03 thread starter macrumors 6502

    Joined:
    Mar 8, 2007
    #3
    Looks like i'm going to have to restore my iPod then. Thanks man!
     
  4. sanford macrumors 65816

    Joined:
    Jan 5, 2003
    Location:
    Dallas, USA
    #4
    I second the restore. I've even had this still happen with recent iPhones. Art that's in the tags for each song, no problem, ever. Art that uses Apple's system of pointing to a single piece of art in an art database for all songs in an album, they sometimes get scrambled.

    In case anyone stumbles across this for an iPhone issue, you can use restore from backup and not wind up restoring corrupt artwork references. You have to remember iPhone backups don't backup music or media, only phone data and prefs, app data and prefs, etc. Music and other media just gets copied back over fresh from iTunes -- and fixes any corrupt artwork reference issues.
     
  5. aross99 macrumors 68000

    aross99

    Joined:
    Dec 17, 2006
    Location:
    East Lansing, MI
    #5
    I run into this for Podcasts on my iPhone. I find that I can simply uncheck "sync podcasts", sync, and then check "sync podcasts", and then sync again.

    I think simply resyncing the songs would work, but if the affected songs aren't grouped in some way so you can easily unsync/sync them, then a restore might be just as easy...
     
  6. NeoMac macrumors regular

    NeoMac

    Joined:
    Feb 10, 2006
    #6
    I have had this issue several times. All I usually do is remove all the music from my Ipod and then resync and that takes care of the issue for me.
     

Share This Page