Artwork looks right on iTunes, wrong on iPhone!?

Discussion in 'iPod' started by gpezzino, Dec 6, 2008.

  1. gpezzino macrumors member

    Joined:
    Mar 27, 2008
    #1
    I am having a weird problem. Some songs on my iPhone display a wrong artwork - for example, a Bruce Springsteen song will display a U2 artwork. But the same song shows the correct artwork on iTunes! If I delete the artwork in iTunes and re-copy it, then it is shown correctly also on the iPhone, but after a few days a new set of songs will experience the same problem.

    Does anyone have any ideas of what is going on, and how to fix it?

    Thanks!
     
  2. vandlism macrumors 6502

    Joined:
    Jun 20, 2007
    #2
    Best option would be to re-sync all of your music to your iPhone. Wipe it clean of all music, and put it back on. Something got messed up and it needs to be reset.
     
  3. iParis macrumors 68040

    iParis

    Joined:
    Jul 29, 2008
    Location:
    New Mexico
    #3
    This happened to me on my iPod classic, 1G Nano, and me friends' classic.
    The problem showed up mostly when space was running out.
    As stated, wipe all the music off then put it back on.
    If that doesn't solve it, wipe the music again then put it back on put not all of it so that there is more space left.
     
  4. gpezzino thread starter macrumors member

    Joined:
    Mar 27, 2008
    #4
    Fixed, at least for now

    I did what you recommended and re-sync the playlist and now the right artwork is displayed.

    This is the second time that it happens. And, in my case at least it was not because of lack of space - I have 1.2 GB free memory on the iPhone.

    Thanks for your help!
     

Share This Page