[ASK]Drive Wont Accept the Disc except in Windows Mode

Discussion in 'Mac mini' started by cc devil, Sep 13, 2012.

  1. cc devil macrumors newbie

    Joined:
    Sep 13, 2012
    Location:
    Jakarta
    #1
    Hi,

    i just bought a new modded Mini Mac 5,2 with built in an optical drive.
    About a couple weeks a go, the drive wont accept the disc except :
    1. I put the disc 1st when booting
    2. Im in Windows Mode using bootcamp


    If i use the 1st condition, it will read the disc normally. It even will do installation of Mountain Lion. And when i eject the disc (in OSX mode), and re insert the disc several times (about 3 times), it will still take it. But usually after the 4th insert, it wont feed the disc anymore.
    And also, if the drive stays in idle or no disc in it, the problem will start. The drive wont feed the disc.

    If i use the 2nd condition, the drive works fine and flawlessly.

    So, the problem will only occur when i use the OSX mode and didnt put the disc when booting.

    Anyone ever have this kind of problem ?

    Thanks before.
     
  2. Omnius macrumors 6502a

    Joined:
    Jul 23, 2012
    #2
    This is the risk with a modded computer. Tell us more about the mod. Can you show up pictures of the insides? Is it like a 5,2 stuffed in a 4,1 case? To me it sounds like it wasn't connected properly or the optical drive is defective.
     
  3. cc devil, Sep 13, 2012
    Last edited: Sep 13, 2012

    cc devil thread starter macrumors newbie

    Joined:
    Sep 13, 2012
    Location:
    Jakarta
    #3
    @omnius : if its not connected properly, why in windows mode the drive works fine. :rolleyes:

    Heres the pics of my Lovely :eek:
    [​IMG]
    [​IMG]
    [​IMG]
     
  4. Omnius macrumors 6502a

    Joined:
    Jul 23, 2012
    #4
    If that's the case, it sounds like a bizarre software issue. But I've seen issues where one OS found a faulty hardware problem to be worse than others. Personally, I'd open the case and check all the connections but I have no idea what your warranty situation might be. Where did you buy it?
     
  5. cc devil thread starter macrumors newbie

    Joined:
    Sep 13, 2012
    Location:
    Jakarta
    #5
    Im still looking for this problem. If this is the HW issue, i suppose to have the same problem on windows right ?
    Software ? Is there anything related to EFI update ? :confused:
     
  6. cc devil thread starter macrumors newbie

    Joined:
    Sep 13, 2012
    Location:
    Jakarta
    #6
    Today, i just updated the EFI to EFI 1.6. And the problem still there. :cool:

    And also, i found a new "weird behaviour" with the drive. I can make the drive feed the disc without the need to restart the mac and put the disc into it. The drive will feed my disc if i click the System Preferences => CDs & DVDs icon.

    I think there is something related to waking up the drive. But i can't find how to set or modify the waking up the drive option. Anyone here ever had this kinda problem ?

    Thanks
     

Share This Page