Assassins Creed Odyssey in bootcamp and windows 10

Discussion in 'Mac and PC Games' started by ezsobre, Oct 13, 2018.

  1. ezsobre macrumors member

    Joined:
    Dec 18, 2007
    #1
    Has anyone gotten Assassins Creed Odyssey to actually work on a Mac or MacBook running bootcamp and windows 10? I have seen a number of threads but no solution. I have a 15” 2018 MacBook Pro touchbar running Windows 10 in bootcamp. Windows and drivers all up to date. Graphics is Radeon 560 Pro.

    No matter what I try the game freezes/crashes at the splash screen. The splash screen comes up but nothing else happens. A second window opens up and is al black and if you alt tab into that window you can’t do anything. GPU usage appears to be nil when looking at task manager as though the graphics card is not being triggered at all.

    Running as admin doesn’t work. Installing on a separate drive and running from there doesn’t work (as some threads I’ve seen suggested worked for origins).

    I’ve opened a ticket with Ubisoft and done everything they’ve proposed. But not if that has worked either. These include:

    Reinstalling “DirectX, Microsoft Visual Studio C++, and the Microsoft .NET Framework.”

    “Disabling any startup applications or services that could be causing a conflict with the game itself.”

    “Perform[ing] a clean install of your GPU drivers.”

    “Reinstalling the game on your C drive.”

    “Disabling any overlay or DirectX hooking software before launching the game.”

    None of this has worked.

    I have read on another thread that perhaps the problem is the game can’t play nice with the Radeon 560 pro graphics card.

    Has anyone gotten assassins creed odyssey to work on a Mac running bootcamp and windows 10?

    Thanks
     
  2. wubsylol macrumors 6502

    Joined:
    Nov 6, 2014
    #2
    I don't have this specific Mac or game, however I do play other modern games on my iMac via Bootcamp. Have you updated GPU drivers? The drivers Apple provide are over a year old; check bootcampdrivers.com for an updated version. Just running the Apple Software Update does not give you the _latest_ GPU drivers.
     
  3. ezsobre thread starter macrumors member

    Joined:
    Dec 18, 2007
    #3
    Thanks for the suggestion! So i went ahead and installed the drives from bootcampdrivers.com. Updated version of the radeon drivers as of 10.10.18. This did not solve the problem.
     
  4. wubsylol macrumors 6502

    Joined:
    Nov 6, 2014
    #4
    Ohh, I'm not sure then sorry dude! This kind of thing is why I prefer playing on consoles lol
     
  5. ezsobre thread starter macrumors member

    Joined:
    Dec 18, 2007
    #5
    Hi everyone. I can happily report that for me, installing the game to an external drive and running it through steam worked. I have the latest drivers from bootcampdrivers, and am running it on an external USB C drive. Load times are a hint slower, but the game runs very smoothly.
     
  6. mhd2100 macrumors member

    mhd2100

    Joined:
    Nov 3, 2016
    #6
    This is an issue that was present with Assasins Creed: Origins too. Installing to an external drive is the only way to get the game working.
     
  7. AvengerNX08 macrumors member

    Joined:
    Nov 21, 2015
    Location:
    Germany
    #7
    You can actually create a virtual harddisk and install the game on there. I think that the way the Bootcamp drive is formatted collides with a number of games. Skyrim or Assassins Creed Origins for example.

    As for Odyssey: It ran perfectly since day one. The quality and performance was surprisingly good as well. I can only imagine what the Vega 20 will be able to achieve here! :D
     

Share This Page

6 October 13, 2018