AssistantServices.framework bouncing on dock

Discussion in 'OS X Mountain Lion (10.8)' started by Anti-Lucifer, Jul 25, 2012.

  1. Anti-Lucifer macrumors 6502a

    Joined:
    Mar 9, 2012
    #1
    Anyone else seeing this strange behavior? When activating Dictation to talk type, this AssistantServices.framework folder appears bouncing on the dock and the only way to rid it is to force-quit the folder. Dictation still works but this folder shows up??

    :confused::confused::confused:
     
  2. dnb34tz420 macrumors newbie

    Joined:
    Aug 5, 2011
    #2
    I have the same exact problem... It just stops though I'm not sure why. it's working fine now considering I just typed all this with the dictator
     
  3. sammyb123456 macrumors newbie

    Joined:
    Jul 25, 2012
    #3
    same problem here

    Also having the same issue. Will ring apple and ask them today though.
    I'll keep you updated and please let me know if you find anything too.
     
  4. Anti-Lucifer thread starter macrumors 6502a

    Joined:
    Mar 9, 2012
    #4
    So I reinstalled ML from CLEAN install (this is the 3rd time doing so) - and still, the assistantServices.framework folder shows up after you initiated a dictation. I'm going to submit to apple bug report.

    Dictation still works fine just that stupid folder keeps bouncing and won't go away until a force-quit. I think it may be a certain app I installled that may of caused this behaviour - since upon a very fresh install, there is no problem whatsoever. It isn't until I have dockview installed, it does this. Removing dockview completely doesn't fix it.
     
  5. ericsvizeny macrumors newbie

    Joined:
    Dec 7, 2010
    #5
    Same problem here, I have not figured out how to fix it yet.
     
  6. DanTheAppleMan macrumors regular

    Joined:
    Jul 26, 2012
    Location:
    UK
    #6
    Here's a workaround:

    Head over to /System/Library/PrivateFrameworks/AssistantServices.framework/Versions/A/Resources/Info.plist and open it in TextEdit or similar.

    Paste this between the fourth and fifth lines:
    Code:
    
    <key>NSUIElement</key>
    <string>1</string>
    
    so you end up with this:
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    
    <key>NSUIElement</key>
    <string>1</string>
    
    	<key>BuildMachineOSBuild</key>
    	<string>12A251</string>
    	<key>CFBundleDevelopmentRegion</key>
    	<string>English</string>
    This should prevent the framework from appearing in the dock.

    Happy Dictating!
     
  7. spectre4188 macrumors newbie

    Joined:
    Jul 26, 2012
    #7
    After changing the folder and file permissions, I was able to edit the file accordingly, but unfortunately, this didn't help. Did it work for anyone else? Maybe it's just me.. :)
     
  8. AlexHunter macrumors newbie

    Joined:
    Jul 26, 2012
    #8
    Worked fine for me. Perhaps you didn't place the code between

    "<dict>" and "<Key>Build...?"
     
  9. smithnathan1 macrumors newbie

    Joined:
    Mar 22, 2011
    #9
    I am running Mountain Lion on MacBook Pro (late 2011) with this problem when using dictation. However my Mac mini (mid 2011) is running Mountain Lion and is not experiencing this problem

    I have been working with an AppleCare Senior Advisor on this issue since Mountain Lion was released on the Mac App Store on Wednesday. She has had me run a capture data and send her the results. She said she would escalate the issue to the engineering team and let me know what the fix will be.

    Once I recieve a response from the advisor I will let you all know
     
  10. sammyb123456 macrumors newbie

    Joined:
    Jul 25, 2012
    #10
    This worked!

    Just wanted to say that this worked for me. Thank you very much!!
     
  11. DanTheAppleMan macrumors regular

    Joined:
    Jul 26, 2012
    Location:
    UK
    #11
    You're most welcome. Glad I could help.
     
  12. Anti-Lucifer thread starter macrumors 6502a

    Joined:
    Mar 9, 2012
    #12
    I'd like to thank DanTheAppleMan for fixing this problem, apple geniuses can't even fix! :apple::apple::apple:

    Finally a worthy macrumors member who actually contributes to helping others. Unlike the many here who are a waste of breath on this board, DanTheAppleMan is a valuable asset to Macrumors!

    Thank you sir, you are one smart man. Have a great weekend!
     
  13. DanTheAppleMan macrumors regular

    Joined:
    Jul 26, 2012
    Location:
    UK
    #13
    Thank you very much, it really means a lot to hear that others truly appreciate my work to the extent that a generic 'Thanks' will not suffice.

    After not such a successful day, reading your post has lifted happiness from deep within me allowing today to end with only positive thoughts and a smile which I rarely wear.

    I'm glad I decided to join Macrumors.

    Have a great weekend yourself, and enjoy dictating to your Mac!
     
  14. skiffx macrumors 6502a

    Joined:
    Feb 5, 2008
    #14
    Much obliged I thought it was little snitch bugging out :) I also had dockview installed and then uninstalled as someone mentioned above.
     
  15. russdonald macrumors newbie

    Joined:
    Jul 29, 2012
  16. bbush331 macrumors newbie

    Joined:
    Aug 8, 2012
    #16
    bouncing file on dock

    I am having same issue with bouncing folder how tried to do what Dan said and i don't have permission to edit file, how can i disable file permissions or is there a workaround this
     
  17. DanTheAppleMan macrumors regular

    Joined:
    Jul 26, 2012
    Location:
    UK
    #17
    Obtain permissions to edit info.plist

    To obtain the required permissions:

    Navigate to '/System/Library/PrivateFrameworks', right click on 'AssistantServices.framework' and click 'Get Info'.

    Click the lock symbol in the lower right corner and enter your account password to unlock the sharing and permissions pane.
    lock symbol.png

    Now click the '+' button in the lower left corner and select your username.
    + button.png

    Click on the drop-down menu to the right of your username and select 'Read & Write'
    username permissions.png

    Finally, click the settings button in the lower left and select 'Apply to enclosed items'
    apply to enclosed items.png

    You should now be able to edit the Info.plist file successfully.
    If you cannot, simply repeat the above procedure by right-clicking on the Info.plist file itself. (There is no need to apply to enclosed items this time)
    If for any reason you still cannot edit the file, you may need to repair permissions in Disk Utility.
     
  18. AlexHunter macrumors newbie

    Joined:
    Jul 26, 2012
    #18
    You could make a copy of the file on your desktop, edit it properly, then drop the file into that folder and give it permission to replace. I'm pretty sure that should work.
     

Share This Page