Associating extensions to a program doesn't work right?

Discussion in 'macOS' started by Mindflux, Nov 3, 2007.

  1. Mindflux macrumors 68000

    Mindflux

    Joined:
    Oct 20, 2007
    Location:
    Austin
    #1
    I have 'the unarchiver' installed, and I took foo.zip and told it to Open with The Archiver... ok that works, but bar.zip doesn't open with it.

    So I change the properties of bar.zip to open with unarchiver and the icon association changes..but then I select "change all".. and the dialogue box pops up saying "Do you want to change all .zip files to use the unarchiver", and I select yes..or ok or whatever... and the icon goes back to the archive utility (white paper w/ zipper)....

    So, if I do a global change this breaks, but if I do a local file change it works..

    what the heck is going on? I had this issue with tiger too.
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
  3. Mindflux thread starter macrumors 68000

    Mindflux

    Joined:
    Oct 20, 2007
    Location:
    Austin
    #3

    Yes, but I also have this problem with other extensions. Say I want .doc to open up with pages.

    Same thing. I can open "resume.doc" and associate it with pages, but if I say "change all".. dog food.doc still opens with something other than pages (say, Office 2004)
     
  4. Mindflux thread starter macrumors 68000

    Mindflux

    Joined:
    Oct 20, 2007
    Location:
    Austin
    #4
    Stuffit seems to work fine here. I guess I'll use that until the unarchiver gets fixed.
     
  5. Mindflux thread starter macrumors 68000

    Mindflux

    Joined:
    Oct 20, 2007
    Location:
    Austin
    #5
    Any fix in sight? :(
     

Share This Page