Asus GTX750ti and Mac pro

Discussion in 'Mac Pro' started by Henrik-, Nov 16, 2016.

  1. Henrik-, Nov 16, 2016
    Last edited: Nov 16, 2016

    Henrik- macrumors newbie

    Henrik-

    Joined:
    Nov 16, 2016
    #1
    Hi!

    Bought an Asus Gtx 750ti, a model with one fan, for my Mac pro 3.1 (2008).

    Im on 10.11.4 with divers supposed to work. I can see both the original card and the 750ti in the nvidia web driver. I have both installed in the computer.

    But i get no signal from the 750ti to my screen. Not via dvi or hdmi. And i want to use dual-link dvi. Should i return it and try an other card? Read that some ASUS Cards might not work and so on.

    Theres a EVGA 750ti availible second hand here.
     
  2. CreatePro macrumors newbie

    CreatePro

    Joined:
    Feb 19, 2014
    Location:
    UK
    #2
    Hi Henrik, It could be worth trying the EVGA version. Are you using any adapters? Also is it the 2600XT you have in there also?
     
  3. Henrik- thread starter macrumors newbie

    Henrik-

    Joined:
    Nov 16, 2016
    #3
    Hi m8! No adapters, the 750 is not in need of extra power or power cable adapters. And no adapters between the screen and the card. If this is what you mean.

    Yes i have the original gfx card installed too, for startup.

    I acutally ordered a EVGA Gtx 950 ssc today, and will return the 750. Really like the no extra power of the 750 and dont need that much of extra gfx-power, just decent fps in cs:go. But now ill have to look after adapters for the extra power cables for the 950 i guess.. Hope it will work out!
     

Share This Page