AT&T iPhone 4S drops connection every 30 seconds

Discussion in 'iPhone Tips, Help and Troubleshooting' started by amd is the best, Nov 26, 2011.

  1. amd is the best, Nov 26, 2011
    Last edited: Nov 26, 2011

    amd is the best macrumors member

    Joined:
    Aug 8, 2011
    #1
    Hey Guys,

    This is now the second time my phone has done this. Previously I restored it and it stopped the issue but now it has started again. I did a quick search and could find any results so I'll post it up here.

    I'm on iOS 5.0.1 and am using a 16GB AT&T iPhone 4S. Every 30 seconds (exactly) the cell service will drop and go to "Searching..." 30 Seconds later it will reconnect and function normally. Send texts, browse the web, etc. Then 30 seconds later it will drop again.

    I called AT&T last time and the saw no connections issues or anything on their end although they mentioned possibly needing a new SIM card. I tried restoring just in case and the issue was solved for maybe two weeks. Not sure.

    Another thing to add is that just seconds before the phone drops connection, it'll hang (glitch, pause) in whatever I'm doing. Typing for example. Then right after it drops, all of the letters I may have typed while it was hung show up.

    If I turn of cellular data the connection issues are gone as well.

    Anyone have any idea what may be happening or has anyone else seen this?

    I plan on restoring it again and it'll most likely take care of the issue again, at least temporarily.

    Thank you in advance,
    Nick
     
  2. amd is the best thread starter macrumors member

    Joined:
    Aug 8, 2011
    #2
    Went the the Apple store and they replaced it no questions asked. They mentioned that they had never seen this issue before and minutes later a customer walked in with an identical issue.

    Everything is working good to this point. Fingers crossed.
     

Share This Page