at my wits end with SLS mail

Discussion in 'Mac OS X Server, Xserve, and Networking' started by superosky, Apr 1, 2011.

  1. superosky macrumors newbie

    Mar 3, 2009
    So i have everything set up in SLS running perfectly: ichat, address book, ical, web pages, time machine, file sharing.....everything except email.

    I've signed up for and tried to copy their email set up and it just won't work out for me. I know that DNS is running locally and working because the network utility maps everything out and it works but here are my settings.


    A host is set to my external ip address
    CNAME pointing to
    MX record

    machine record for at ip address
    alias pointing to
    mx record

    email server setting:
    host name:
    smtp enabled allowing incoming mail

    so the problem is that when I set up a clients to look for either or I get the error message that the "smtp server is not responding"

    I can't seem to get it to respond no matter what i do.

    Please help??
  2. Saar macrumors newbie

    Jan 22, 2008
    #2 is a private IP.

    You need to get yourself a public IP address.
  3. ramases macrumors member

    Jan 14, 2008
    How is your server connected to the internet? Do you have port forwarding/NAT/Port redirection enabled on your router to route traffic received on your external address to SLS?

    eg <public Ip address> port 25 NAT to <> Port 25

    your A host address on GoDaddy may send the SMTP mail to your router, but the router needs to know where to deliver it on your LAN, ie what private IP address the server sits on.
  4. superosky thread starter macrumors newbie

    Mar 3, 2009
    okay so i do have a public ip address which the a host from godaddy then points to my AE router. The router is set to share the public ip address and i have the default host at which is the SLS machine. I have the router set up to open ports 25,110,143,587,993,995 in order to use the mail service HOWEVER I used a port checker and it sill shows that ports 25 and 587 are CLOSED and that ports 110,143,993,995 are OPEN.

    I called my ISP and they deny that they are blocking any ports. I have a business T1 from windstream. The smtp mail did work at one point but has stopped now for the obvious reason that port 25 is closed and I cannot seem to open it. I don't know what else I should try since the settings appear to allow port 25 traffic but multiple port checkers show it as closed.
  5. Alrescha macrumors 68020

    Jan 1, 2008
    I don't know what the result of using both 'default host' *and* individual port mapping is, but at best it's undefined. I'd suggest using one or the other. I have no issues with Snow Leopard Server and an old Airport Extreme using port mapping (no default host). Default host is just exposing your machine to probes on every port in existence.

    Some simple debugging: try telnetting from some other machine on your local network to your server port 25, e.g. 'telnet 25'. If you get connected to SMTP then your problem is elsewhere (barring some firewall rules you might have manually configured in your server). If you don't get connected then the problem is the server and you have to figure out why SMTP isn't listening.

    If you can telnet to your server on the inside, but not from the outside then you have either a router problem or an ISP problem. As for my old Airport Extreme, I found that upgrading to the latest firmware (7.5.2) caused no end of problems, I downgraded to the previous version (7.4.2) and all is well.

  6. superosky thread starter macrumors newbie

    Mar 3, 2009
    okay so I did a local telnet from a client and I was able to login to on ports 143, 993, 995 but NOT on ports 25 and 587. I guess this means the router is free and clear however I still cannot understand why SLS is closing those ports. I dont have firewall services enabled and when I did use it I opened up everything but it still didn't work. ????
  7. Alrescha macrumors 68020

    Jan 1, 2008
    The mostly likely suspect is that SMTP is not running. There may be nothing blocking those ports, there is just nothing listening. Try the telnet from a Terminal window on the server itself to and If you can't connect, it may be time to debug your mail configuration on the server.

  8. superosky thread starter macrumors newbie

    Mar 3, 2009
    so i'm trying to use the firewall with sls and i have opened up every port, or so I think i have done it succesfully, and yet the only port that i can see 143 from the internet. Even internally I cannot telnet to any other port other than 143. I have no idea why sls is blocking every port even thought I'm telling it to open up everything!
  9. matspekkie, Apr 4, 2011
    Last edited: Apr 4, 2011

    matspekkie macrumors member

    Oct 19, 2010
    just my 5 cents

    Are u using SSL mind you that will change the ports and thus not use smtp 25.
    as far as the mail are you mail to or if you are using the last one you have to change this in the mail server. also a lot of iso providers will not allow you to send from smtp port 25 so you will have to use their smtp as a smart host.

    so SSL on smtp will be 587, imap incoming SSL on 143

    domainname servername

    also did you forwarded the correct ports to your server?? wan ip port -> server internal ip

    p.s wan port 143 -> lan serverip port 143
    587 -> lan serverip port 587

    hope this helps you
  10. superosky thread starter macrumors newbie

    Mar 3, 2009
    I just can't understand this. I have the router essentially forwarding everything to the SLS machine. I go to the mail tab and I disable smtp, pop, imap and I get the port connections refused on 25,110,143, 587.

    Then I enable smtp, pop and imap and I CAN see ports 110,143 but still cannot see ports 25 and 587 either locally from a telnet or from the internet. I disabled all firewall services just in case.

    It just doesn't make sense what is going on. Anyone have any ideas??
  11. superosky thread starter macrumors newbie

    Mar 3, 2009
    So i ran a port checking tool and these are the results. I expected port 80 to be closed because I disabled the web service however mail is on and smtp is enabled with ssl and yet 587 continues to be closed as if nothing were listening on that port.

    Results from scan of ports: 0-1055

    7 Ports Open
    4 Ports Closed
    1045 Ports Stealth
    1056 Ports Tested

    Ports found to be OPEN were: 22, 110, 139, 143, 548, 993, 995

    Ports found to be CLOSED were: 25, 80, 443, 587

    Other than what is listed above, all ports are STEALTH.

    TruStealth: FAILED - NOT all tested ports were STEALTH,
    - NO unsolicited packets were received,
  12. superosky thread starter macrumors newbie

    Mar 3, 2009
    error message

    I looked at the error log file specifically for smtp and it says the following:

    server postfix/master[38346]: warning: valid_hostname: misplaced delimiter:

    server postfix/master[38322]: fatal: file /etc/postfix/ parameter myhostname: bad parameter value:

    I know that these are settings in the /etc/postfix/ file but unsure where in the file the error is and how to fix it?
  13. superosky thread starter macrumors newbie

    Mar 3, 2009
    Fixed it

    I edited the file and replace the "myhostname" with server.$mydomain and then everything started working. The smtp is responding now on both 25 and 587 and I can send and receive mail perfectly.

    I want to thank everyone here who pointed me in the right direction. Without your help I could not have fixed this problem.

    many thanks!

Share This Page