AT&T blocking SMTP mail servers?

Discussion in 'iPhone' started by dacreativeguy, Nov 7, 2009.

  1. dacreativeguy macrumors 68020

    Joined:
    Jan 27, 2007
    #1
    I use pair.com for email and haven't had any problems will outgoing mail from my iphone until today. When using wifi, I can send just fine. But when I am in 3G mode, I get errors that the iphone cannot connect to the outgoing mail server. I also noticed a new entry for "AT&T SMTP Server" on the iphone, which I didn't add. Is AT&T blocking non AT&T SMTP servers? If so, why and is there any way to get around it?
     
  2. daihard macrumors 6502a

    daihard

    Joined:
    Feb 19, 2008
    Location:
    Seattle, WA
    #2
    I'd doubt it. I was just able to send my Google mail via the default Google SMTP server on 3G.
     
  3. sidewinder macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #3
    No, they are not blocking SMTP servers. But they may be blocking port 25. I use port 587.

    No, port 25 is okay too.......

    S-
     
  4. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #4
    I have no issues with any of my email servers. Have you checked to make sure your SMTP server isn't the culprit?
     
  5. CocoaPuffs macrumors 68010

    Joined:
    Aug 23, 2008
    #5
    AT&T has no reason to block SMTP servers, perhaps you should simply check if that particular server is down.
     
  6. dacreativeguy thread starter macrumors 68020

    Joined:
    Jan 27, 2007
    #6
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_1_2 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7D11 Safari/528.16)

    Like I said, it works fine over wifi but fails over 3g. That puts the focus on AT&T. After doing some research it looks like AT&T may be blocking unauthenticated smtp server connections. Someting definitely changed in the last week or so.
     
  7. sidewinder macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #7
    AT&T has no way of knowing if you are using an unauthenticated SMTP connection or not. All they can do is block ports. They are not blocking port 25 or 587.

    What provider is you wireless net connected to the Internet through? What is the name of the SMTP server you are using?

    S-
     
  8. emuyshondt macrumors member

    Joined:
    Jul 9, 2009
    #8
    It could be that something changed at your SMTP server if this worked in the past. Perhaps they no longer allow e-mails to be sent over that server unless you are directly attached to its network. If by WiFi you mean you are attached for example to your home ISP, then sending through its smtp server would work but when you are on 3G or a different WiFi connection it won't.

    This is done for security reasons and to prevent spammers from using open SMTP servers to do their deed.

    With the iPhone, try going to:

    Settings-> Mail, Contacts, Calendars-> Your Account Name -> SMTP

    Press on the server name and make sure "Other SMTP servers" includes AT&T SMTP Server and that it is turned on. This allows you to use the cwmx.com smtp server when you are connected to 3G.

    With this setting the phone will use your SMTP server when connected to it over WiFi or cwmx.com when connected over 3G.
     

Share This Page