AT&T Carrier Unlock Problem with iPhone 3G

Discussion in 'iPhone' started by SouthPhillyPT, Apr 23, 2012.

  1. SouthPhillyPT macrumors newbie

    Joined:
    Jan 24, 2008
    #1
    After requesting for a carrier unlock with AT&T, I received their confirmation email and followed the directions. I have been trying to restore my iPhone 3G using the latest iTunes installed on a MacBook with OS X Lion. I have been unable to restore and use my phone. I am stuck at restoring it over and over giving me an error code of 1015. Can anyone help me to resolve this problem?

    Thank you very much.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    You had the iPad bb installed before?
    That's probably your prob.
     
  3. SouthPhillyPT thread starter macrumors newbie

    Joined:
    Jan 24, 2008
    #3
    Is there a fix to this? I have tried RecBoot 2.2 but I am still stuck at the same connect your iPhone to iTunes stage. I would appreciate step by step instructions on how to undo this problem.
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    You need a custom 4.2.1 created with redsnow.
    Then once you restore to that you need to reflash the iPad bb and install ultrasnow.
    In other words the carrier unlock is pointless in an iPhone 3G or 3GS with the iPad bb.
    Look at iclarified.com for a tutorial.
     
  5. SouthPhillyPT thread starter macrumors newbie

    Joined:
    Jan 24, 2008
    #5
    I apologize for not being able to follow you. How do I create a custom 4.2.1 via redsnow and reflash? I cannot seem to find it on the iClarified.com website.

    Thanks for your patience with me.
     

Share This Page