AT&T customer service is AWESOME. (i.e. inept)

Discussion in 'iPhone' started by goodcow, Oct 25, 2008.

  1. goodcow macrumors 6502a

    Joined:
    Aug 4, 2007
    #1
    My bill cycle ends on the 13th.

    My 9/13 bill said:
    CREDIT BALANCE $-205.87
    TOTAL CURRENT CHARGES $72.04
    BALANCE -133.83

    Which was ... completely wrong. That included a $25 credit for 3G data problems... the rest was mysterious to me. I eventually got a letter in the mail from AT&T, saying that they had misapplied $180.87 in payments to my account that was supposed to go to another account.

    So then $-133.83 minus the $180.87 credit was $47.07 due. Which I paid.

    I currently see:
    Total Amount Due $0.00

    So what's the problem? It's 10/25, my bill cycle ends on the 13th, and I don't have a 10/13 bill.

    The AT&T rep who has me on hold now, says that he sees I have a $-133.83 credit and can see my 10/13 bill. He can't explain why I can't see a 10/13 bill under my online account. He then said he was going to send another hard copy of my 10/13 bill (even though I didn't get a first hard copy) and then he ran into difficulties and now I'm on hold.

    Oh AT&T, I <3 you so much!

    I don't believe my 10/13 bill exists at all, and my account is probably completely f'ed up, but knowing AT&T so far for just three short months, I bet they'd end up sending me some huge $500 bill down the line with "late fees" if I tried to ignore this.
     
  2. goodcow thread starter macrumors 6502a

    Joined:
    Aug 4, 2007
    #2
    So after an HOUR on the phone with them... they connected me to billing.

    Billing saw my October statement, due Nov. 8th for $75.01. Verified I couldn't see it under my online account and that a paper bill wasn't mailed out.

    This was contrary to what the other rep said, where I had a $133 credit. So had I not been adamant and pushed him for 30 min, I would've been hit with late fees.

    So my bill was $75.01... I got a $25 credit, so she said my new balance, which was invisible online, was $50.01 (even though since the credit should lower the tax as well, it should've been less)

    So I just paid the $50.01 due Nov. 8th and now my account says:

    Last Payment Received $50.01
    Credit Balance ($75.01)

    When the balance should be zero.

    What the **** is wrong with this company?

    I'm supposed to get a call back later once my online account is "fixed."
     
  3. daisuke07 macrumors regular

    Joined:
    Oct 25, 2008
    #3
    I am having the same problem as you. There is a $40 activation fee when you buy a phone from AT&T but the lady said we would only have to pay like $25 (or something like that) if we donated to a charity and that they would take it off our bill. But instead they never did for weeks and when I checked my bill on my iPhone it said it was $160 when it should have only been $120. My mom looked at her bill statement online and it showed that she still paid $160. So now we have to go and dispute the bill at AT&T and they had better give us something in return :p

    Bad customer service from AT&T.
     

Share This Page