iPhone AT&T kicked me off 4G after jailbreak?

Discussion in 'Jailbreaks and iOS Hacks' started by PatrickW98, Mar 26, 2013.

  1. PatrickW98 macrumors 6502

    PatrickW98

    Joined:
    Apr 26, 2012
    Location:
    Subrubs of Chicago, IL
    #1
    I have a jailbroken iPhone 4S on iOS 6.1.2. After jailbreaking I no longer get a 4G connection, only a EDGE connection. Did AT&T kick me off for jailbreaking? How can I get my connection back because EDGE is SOOO slow. >_>
     
  2. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #2
    i doubt jailbreaking would have this side effect. did you notice it after installing something from cydia or immediately after jailbreaking?

    have you tried rebooting your device? resetting network settings?
     
  3. ~Ks383~ macrumors 6502

    Joined:
    Jul 6, 2011
    #3
    As far as I know AT&T does not block jailbroken phones from using any part of their network. I also have an iPhone 4S on AT&T and do not have this issue. Maybe a tweak you installed is causing the issue. What tweaks do you have installed?

    Edit: I second the idea of trying resetting network settings if you haven't already tried that
     
  4. PatrickW98 thread starter macrumors 6502

    PatrickW98

    Joined:
    Apr 26, 2012
    Location:
    Subrubs of Chicago, IL
    #4
    Well I noticed I no longer got a 4G connection after I deleted the native Weather app using iFile. Could this have somehow caused the problem?

    I have tried both rebooting my device and resetting network settings.
     
  5. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #5
    did you have it jailbroken for a while before you deleted the native weather app?
     
  6. bun.bhay macrumors member

    Joined:
    Dec 6, 2011
    Location:
    Seatown
    #6
    try also checking your toggles whether it maybe ncsettings, sbsettings or the alike to see if you accidently disabled the 3G/4G connection.
     
  7. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #7
    No they didn't and the jailbreak wasn't the cause either. You probably installed something that messed it up.
     
  8. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #8
    Why on earth would you delete the weather app??

    Deleting system files is never a good idea.
     
  9. kalirob99 macrumors 68000

    kalirob99

    Joined:
    Dec 24, 2008
    Location:
    California
    #9
    I'm wondering this myself. I can understand wanting to get rid of the Stocks app maybe, but the Weather app?
     
  10. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #10
    Maybe he uses another weather app? Everyone has different preferences so we shouldn't judge him or her for not wanting the stock weather app:p
     
  11. kalirob99 macrumors 68000

    kalirob99

    Joined:
    Dec 24, 2008
    Location:
    California
    #11
    I don't see the reason to remove any built in app that comes default. It's like playing Jenga with over mitts on if you have no idea what your doing.
     
  12. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #12
    I'm not saying I would. I wouldn't ever delete any built in app by means of the file system. I would just hide it.

    One can never guess another person's motive sometimes:D
     
  13. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #13
    It is not using another app but deleting a stock build in app means deleting system files which might render the device unusable.

    If you don't want it on your screen hide it with Poof!, SBsettings or springtomize.
     
  14. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #14
    My guess is the OP uses appsync and didn't want to deal w the weather app. :confused:
     
  15. lukejc1 macrumors 6502

    Joined:
    Feb 6, 2013
    Location:
    Wisconsin
    #15
    Are you using any tweaks like Smart 3G + LTE, BattSaver Pro, or Auto 3G? If so, they probably have something to do with it.
     
  16. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #16
    Time for a restore on your 4S OP.
    You're better off stock anyway.
    This way you wont delete the phone app and then wonder why you cant call people:D
     
  17. BrandonHacks macrumors regular

    BrandonHacks

    Joined:
    Aug 21, 2012
    Location:
    Texas
    #17
    Before doing a restore maybe another 4s user can upload the weather app and you can try to see if that will fix it.
     
  18. applepie555 macrumors regular

    Joined:
    Aug 7, 2012
  19. PatrickW98 thread starter macrumors 6502

    PatrickW98

    Joined:
    Apr 26, 2012
    Location:
    Subrubs of Chicago, IL
    #19
    I fixed my 4G issue! I had 3G off in the Auxo toggles and I was trying to turn on 4G through NCSettings. NCSettings would only turn on EDGE because 3G was blocked through Auxo.

    Anyways about deleting the Weather App. I watched a video on YouTube and they said doing this through iFile will only hide it. (Which is didn't) Now I regret this because I only wanted to hide it. I did reinstall it. ...but all it does is crash. Anyone want to help me reinstall it?
     
  20. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #20
    When you copy all the weather files back, make sure the owner permissions is set to mobile and not root. Do you still have the springboard app icon? If not, then simply copying files back won't work

    I don't know if the iOS 6 weather app fix in cydia will install a new weather for you or not but you can try. Google it, it's from a source that's not the default
     
  21. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #21
    Handy to kwep track of which apps do what, double functions of apps is bound to get you in trouble.
     
  22. PatrickW98 thread starter macrumors 6502

    PatrickW98

    Joined:
    Apr 26, 2012
    Location:
    Subrubs of Chicago, IL
    #22
    Wow. I'm just lucky. I reinstalled the native Weather app using iFile... it kept on crashing. So I searched up that tweak in Cydia and installed it... now my native Weather app works.
     

Share This Page