AT&T SIM in Verizon 5S - 4G, but no LTE

Discussion in 'iPhone' started by jlaw, Dec 4, 2013.

  1. jlaw macrumors member

    Joined:
    Aug 15, 2007
    #1
    I purchased a 5S at full retail from a Verizon store. When I put my AT&T SIM in, I get 4G but no LTE. I called AT&T and was informed that they could not provision for LTE because my phone is a Verizon phone.

    I know that the hardware is identical as far as LTE band support and that Verizon's phones are supposed to be unlocked. As I understand it, if my phone was not unlocked I wouldn't be able to get any AT&T service at all. So, it appears to be unlocked but not permitted to get LTE.

    Anyone run into this issue? If so, is it resolvable?
     
  2. Diseal3 macrumors 65816

    Joined:
    Jun 29, 2008
    #2
    Did you come from an iPhone before? If not just call and have them provision you for a iPhone. It does not matter where it comes from. Also, if you did not have a LTE phone before you need a ATT LTE sim card.
     
  3. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #3
    I had the same issue.
    In order to add the iPhone LTE plan to your account you will have to give them an imei of an AT&T iPhone 5, 5S or 5C.
    If you give them the verizon iPhone imei their system don't recognize it at all and they can't put in the appropriate data plan.
    So get someone's imei and then call them and give them that imei in order to enable the LTE iPhone data plan on your account.
     
  4. powerstrokin macrumors 6502a

    powerstrokin

    Joined:
    May 18, 2013
    #4
    Go to AT&T and buy a phone, since you want to use their service anyways.

    Problem solved.
     
  5. aznguyen316 macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL
    #5
    Is this the same for an unlocked phone not meant for any carrier? Or how about a Tmobile phone that's been unlocked. Or is it b/c of the Verizon IMEI specifically? Thank you.
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    I'm not 100% but I think its just the cdma Verizon iphones that are not recognized by AT&T.
    I didn't have any problems with factory unlocked iphones with AT&T. I haven't tested out a Tmobile unlocked iphone yet either.
     
  7. jlaw thread starter macrumors member

    Joined:
    Aug 15, 2007
    #7
    :rolleyes: Thanks so much for the informative reply.

    Applejuiced, thank you, I'll give that a try.
     
  8. djuarez03 macrumors regular

    Joined:
    May 23, 2008
    #8
    I had the same problem when I first bought the Verizon iPhone 5S to temporarily use on AT&T. But since I was switching to T-Mobile, I didn't think much of it for the few days I was still with AT&T. Good to know now the reason why the LTE wasn't working. But when I signed up with T-Mobile, there was no problems getting the LTE signal right away. Another knock for AT&T I guess. So glad I switched to T-Mobile.
     
  9. John.B macrumors 601

    John.B

    Joined:
    Jan 15, 2008
    Location:
    Holocene Epoch
    #9
    I used my already-provisioned AT&T SIM card from iPhone 5 in my 5S and LTE on the AT&T network works just fine.

    I would call AT&T and have them send you a new SIM card, or visit their store. Don't tell them about the Verizon iPhone, just tell them you have an unlocked iPhone and want AT&T service.
     
  10. jlaw thread starter macrumors member

    Joined:
    Aug 15, 2007
    #10
    I got it working. I put my SIM into a friend's AT&T iPhone 5, where it immediately got LTE. Took it right back out and put it in my Verizon 5S and it's working fine now.
     
  11. aznguyen316 macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL
    #11
    Great to know this works as well without having to find an AT&T IMEI back route. This thread could be useful down the line especially in google searches.
     

Share This Page