AT&T Unlock & Restore but iphone is stuck

Discussion in 'iPhone Tips, Help and Troubleshooting' started by nelb2, May 28, 2012.

  1. nelb2 macrumors newbie

    Joined:
    May 28, 2012
    #1
    I had my iphone 3GS unlocked via At&t and Apple about a week ago, and when i went to restore the phone it didn't work it didn't give me "your iphone is unlocked" message it said my "sim is not recognized".

    I've tried several sim cards to get this working, digicel, tmobile, at&t and our local gsm telecom bluesky but nothing seems to work. (I live overseas and had the unlock scheduled with a family member) I've also updated itunes and my osx and restarted the computer before doing the restore.

    My theories: a) the internet is just too slow here b)i've jailbroken it too much or c) the phone does not want to unlock...

    I know the unlock works because my younger brother just received an unlocked iphone from the family member who unlocked it for me. So I just need help because I'm not sure where I'm going wrong and I've tried everything I can think of besides sending the phone to Hawaii...to be restored and unlocked there.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Give your iPhones imei number to your family and have them call AT&T again to make sure it's unlocked. Seems like its not right now.
     

Share This Page