Carrier AT&T Wi-Fi calling randomly turning off on iPhone 6

avanpelt

macrumors 68030
Original poster
Jun 2, 2010
2,932
3,802
I've had this happen twice in as many months. Most recently, I noticed that it happened yesterday.

Usually, when I'm at home and on Wi-Fi, my iPhone 6 uses AT&T's Wi-Fi calling. I noticed yesterday that I hadn't seen "AT&T Wi-Fi" in the top-left corner for a few days like I'm used to seeing when at home. I went into Settings --> Phone, and Wi-Fi calling was turned off. I know I didn't turn it off and I doubt my wife would have.

I'm running iOS 9.3.1 and AT&T carrier version 24.1. I haven't seen any carrier update notifications over the last few days since Wi-Fi calling was last on and I haven't done any iOS updates either. It just seems strange that Wi-Fi calling would randomly turn itself off.

Has anyone else experienced this?
 

EDH667

macrumors 6502a
Nov 25, 2009
997
236
Northern California
I had this happen twice on my iPhone SE where the settings toggle turned off. I believe it is possibly on AT&T's side since it is a relatively new feature.
 

jetsam

macrumors 6502a
Jul 28, 2015
578
320
I've had this happen twice in as many months. Most recently, I noticed that it happened yesterday.

Usually, when I'm at home and on Wi-Fi, my iPhone 6 uses AT&T's Wi-Fi calling. I noticed yesterday that I hadn't seen "AT&T Wi-Fi" in the top-left corner for a few days like I'm used to seeing when at home. I went into Settings --> Phone, and Wi-Fi calling was turned off. I know I didn't turn it off and I doubt my wife would have.

I'm running iOS 9.3.1 and AT&T carrier version 24.1. I haven't seen any carrier update notifications over the last few days since Wi-Fi calling was last on and I haven't done any iOS updates either. It just seems strange that Wi-Fi calling would randomly turn itself off.

Has anyone else experienced this?
Yes - I've had the same thing happen with my 6 Plus running 9.3.2 beta 4. (Though it happened about a month ago, too). I'm also running AT&T Carrier version 24.1.

I noticed it pretty much the same way you did. My house is typically at -110dB or lower. Therefore, AT&T Wi-Fi usually kicks in about thirty seconds after I get home. When I had been home for a few hours, and noticed my phone hadn't enabled Wi-Fi calling, I checked the setting, and found it set to Off.

I reported it to Apple as a 9.3.2 beta bug. I've received no response from them, but none of the other bugs I've reported have been ACKed, either.
 
  • Like
Reactions: avanpelt

lordofthereef

macrumors G5
Nov 29, 2011
12,913
3,482
Boston, MA
I've read complaints and people claim that ATT handles wifi calling in an "as needed" basis. Your device will default to the cellular network of that is feasible. In time of weak signal it goes back to wifi calling. Some folks are even saying that weak or spotty signal isn't always enough.

I'm on T-Mobile now and I can say wifi calling is always active on a wifi network that allows it to be. Apparently (again from what I've read) T-Mobile is the only carrier that handles wifi calling as "always on".
 

avanpelt

macrumors 68030
Original poster
Jun 2, 2010
2,932
3,802
I've read complaints and people claim that ATT handles wifi calling in an "as needed" basis. Your device will default to the cellular network of that is feasible. In time of weak signal it goes back to wifi calling. Some folks are even saying that weak or spotty signal isn't always enough.

I'm on T-Mobile now and I can say wifi calling is always active on a wifi network that allows it to be. Apparently (again from what I've read) T-Mobile is the only carrier that handles wifi calling as "always on".
Thanks for the reply but that's not the issue. The problem is that the Wi-Fi calling toggle is being switched off somehow, making the feature not work at all until the Wi-Fi calling feature is manually toggled on again in Settings --> Phone.
 

lordofthereef

macrumors G5
Nov 29, 2011
12,913
3,482
Boston, MA
Thanks for the reply but that's not the issue. The problem is that the Wi-Fi calling toggle is being switched off somehow, making the feature not work at all until the Wi-Fi calling feature is manually toggled on again in Settings --> Phone.
Oh I understand. Very strange. Have you called ATT?
 

imlynxy

macrumors 65816
Mar 8, 2012
1,271
448
I had the same issue couple times last month. I think Att changed/upgraded something there.
Regarding T-mobile and Att vowifi. I like Att vowifi in all aspects better than T-mo. 1. Att has way better vouce quality 2. Att doesn't interrupt, I have interruptions all the time with T-mobile. 3. Att has better hand off to LTE. 4. Personally I like vowifi when cell strength is low.

May be it is only me, but this is how it is on my wifi and location.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.