Carrier AT&T wi-fi Calling stopped working

Discussion in 'iPhone' started by royinla14, Jul 18, 2017.

  1. royinla14 macrumors 6502

    Joined:
    Oct 12, 2011
    #1
    I have iPhone 7 and iPhone 6. Both used to be able to support wi-fi calling at my house. Few weeks ago both stopped working. Tried every single option I read about and no luck. The recent changes in my home were moving from TimeWarner wifi to Spectrum (which is the same company, same router, etc.), added a new Airport Extreme as extender. For a very short period of time I used a new cable modem but then disconnected and went back to the old one (which the wi-fi calling used to work with).

    In addition, even when outside of home, trying with other networks does not work for me anymore.

    Any suggestions?
     
  2. Volgin Suspended

    Volgin

    Joined:
    Jul 17, 2017
    Location:
    Smithfield, RI
    #2
    I'd try a restore as new and set it up again.

    I used to be on att and really liked wifi calling. Then I switched to cricket, which does not have wifi calling. Since ATT owned cricket I was very surprised to learn wifi calling was not supported by cricket.
     
  3. Mlrollin91 macrumors G5

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #3
    What happens when you go on AP mode and only turn on WiFi. Give it 2-3 minutes and it should connect to WiFi Calling. Or, have you tried turning off WiFi Calling and re-enabling it?
     
  4. ACG12 macrumors 6502a

    Joined:
    Jun 9, 2015
    #4
    I'd try resetting network settings on your phone.
     
  5. dmylrea macrumors 68020

    dmylrea

    Joined:
    Sep 27, 2005
    #5
    Beware doing this. When I reset my network settings, I lost all my saved/remembered WIFI networks and their passwords. Years of them that I had accumulated. Gone.
     
  6. Mlrollin91 macrumors G5

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #6
    Yes. That's the point of resetting network settings. It restores everything as default. Including WiFi But if you use keychains, it should restore them. It usually does for me.
     
  7. royinla14 thread starter macrumors 6502

    Joined:
    Oct 12, 2011
    #7
    Tried resetting network, also tried ap mode with wifi. No luck. Only thing I didn't try was erasing phone and set as new which I try to avoid
     
  8. Mlrollin91 macrumors G5

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #8
    Did you try disabling WiFi calling and setting it up again? Did you call AT&T?
     
  9. royinla14 thread starter macrumors 6502

    Joined:
    Oct 12, 2011
    #9
    Yes I disabled wifi and turned on again. Also called att and the rep said it might be because I had apple watch still linked (I returned that watxh). She took it off but still didn't help. Plus as I mentioned that also happens with my other att work phone. Very weird.
     
  10. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #10
    Did you try disabling and then enabling Wifi calling?
    Not just the wifi option.
    Go to Settings/phone/wifi calling.
     
  11. jetsam macrumors 6502

    Joined:
    Jul 28, 2015
    #11
    So, is this correct?

    1. Wi-Fi Calling does not work on two different iPhones
    2. You've tried disabling and re-enabling Wi-Fi Calling on both phones.
    3. You've tried AP mode, then turned Wi-Fi back on. This has *not* made Wi-Fi calling work on either phone.
    4. Wi-Fi Calling works nowhere on two different iPhones. It does not work at home, at work, or at a public Wi-Fi hotspot.
    You mentioned that one of the phones is a work phone. Are both phones on the same account?

    If they are on the same account, I'm inclined to believe this is an AT&T provisioning issue.
     
  12. royinla14 thread starter macrumors 6502

    Joined:
    Oct 12, 2011
    #12
    Everything you mentioned is correct, except the phones are NOT on the same account.
     
  13. jetsam macrumors 6502

    Joined:
    Jul 28, 2015
    #13
    Another thought:
    Do you have VoLTE enabled?

    Settings>Cellular>Cellular Data Options>Enable LTE
    "Voice and Data" should be checked.
     
  14. rzc16512 macrumors regular

    Joined:
    Jun 3, 2015
    #14
    Does wifi calling work in other locations? Does wifi calling work at home if you enable airplane mode and then turn on wifi?

    If the former it's definitely a port/router issue. If the latter then your iPhone is determine that the ATT signal is strong enough to not use wifi calling.
     
  15. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #15
    Might be something the carrier will need to fix on their end with your account.
     

Share This Page