AT&T WiFi Calling No Longer Working?

Discussion in 'iPhone' started by Gmouse, Sep 21, 2017.

  1. Gmouse macrumors regular

    Joined:
    Nov 12, 2014
    Location:
    Lakewood, CO
    #1
    About a year ago, since I worked from home in my basement and got crappy cellular reception, I tried turning on WiFi Calling on my iPhone 7+, and everything got better, also, I could then make calls from my other Apple devices (iMac, MacBook, iPad Pro), and all was fine. I also never got any additional charges from AT&T.

    About two months ago I started getting messages about it no longer working on my devices, and started having issues with my iPhone itself making calls (I could hear, but, called users couldn't hear me). The problem was not coincident to any Apple updates. I turned it off last week, and my iPhone has worked fine since then, even updated to iOS 11 with no issues.

    Was this something on AT&T's end? Have other users had similar issues, and were they just hoping that I'd pay additional fees or something?

    Thanks!
     
  2. ^^BIGMac macrumors 6502a

    ^^BIGMac

    Joined:
    Dec 10, 2009
    #2
    Working fine for me on 10.10.3

    AT&T isn't going to remove this valuable feature.

    What I do wonder, however, is on the iPhone X where is the "AT&T WiFi" display going to show. There is no room for that on the upper right hand side.
     
  3. tivoboy macrumors 68040

    Joined:
    May 15, 2005
    #3
    Att WiFi calling is working fine on iOS 11. What I think MAY have changed is the cell signal strength that the phone considers sufficient for leaving the phone on LTE vs enabling with WIFI calling part. It’s does vary..I know in my area the phone is often NOT on WiFi calling and holding the cell connection longer. Much to mymdisappoit,ent being on a minutes limited plan still.
     
  4. ^^BIGMac macrumors 6502a

    ^^BIGMac

    Joined:
    Dec 10, 2009
    #4
    If it's not going to WiFi calling because it thinks the signal is adequate you can force it to WiFi Calling by activating airplane mode and then turning WiFi back on. This is what I do in my house because the signal fluctuation and I Want a strong signal for phone calls all the time. Just be sure to turn off airplane mode when you leave the house. :D
     
  5. tivoboy macrumors 68040

    Joined:
    May 15, 2005
    #5
    yeah that's what I do when I'm going to do a lot of calls..but its sort of a pain to have to switch off and on, would be nice to have some geo fence or network association that would allow one to set a preference for locked in calling, with the exception being no connectivity.
     

Share This Page

4 September 21, 2017