Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

ericgtr12

macrumors 68000
Original poster
Mar 19, 2015
1,774
12,174
In my house, I have a pretty weak signal, usually hovering between 2 or 3 bars. What this does is cause the iPhone to work hard at keeping a signal, which in turn drains the batteries of both me and my wife's iPhones. We addressed this by getting the ATT Microcell, which has worked great.

I have been able to toggle airplane mode and get it to kick on, but only for a time, then it appears to jump off when it gets a little better signal, which is still subpar. I think I'm stuck on this and forced to keep using the mcell but thought I would see if anyone had any solutions for this.
 

avanpelt

macrumors 68030
Jun 2, 2010
2,956
3,877
Unfortunately, I don't have a solution for you. I get between two and three "dots" in my home -- never more than three -- and my iPhone 6 switches over to Wi-Fi calling automatically usually within five or ten minutes of the time I enter my home and it stays on Wi-Fi calling until I leave my home.

I have noticed that if I put my phone in my pocket, Wi-Fi calling usually activates even more quickly (within a minute or two) presumably because the signal was further degraded when the phone was placed in my pocket. You may want to try that. Good luck.
 

ericgtr12

macrumors 68000
Original poster
Mar 19, 2015
1,774
12,174
Unfortunately, I don't have a solution for you. I get between two and three "dots" in my home -- never more than three -- and my iPhone 6 switches over to Wi-Fi calling automatically usually within five or ten minutes of the time I enter my home and it stays on Wi-Fi calling until I leave my home.

I have noticed that if I put my phone in my pocket, Wi-Fi calling usually activates even more quickly (within a minute or two) presumably because the signal was further degraded when the phone was placed in my pocket. You may want to try that. Good luck.
Thanks for the tip, my problem is that while it's not too hard to get into the mode, it jumps back out on its own. I have actually been fine with just the mcell as it covers this but I got my first call on wifi and was blown away by the quality so now I really want it lol.
 

ericgtr12

macrumors 68000
Original poster
Mar 19, 2015
1,774
12,174
You can put it on airplane mode and turn on wifi while you're home.
Then it will stay on wifi calling until you decide to turn off airplane mode.
All your calls and texts will still come thru.
This works great, I just have to remember to enable it again before leaving the house.
 
  • Like
Reactions: Applejuiced

tdar

macrumors 68020
Jun 23, 2003
2,097
2,516
Johns Creek Ga.
Don't understand why it just doesn't kick in and stay on when connected to wifi.
It's up to the carrier if it works all the time or just if you have low signal. Sadly that's how ATT expects it to work. Seems that Verizon will be doing it the same way. T-Mobile and Sprint do it the way you want it.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.