At the end of my tether with 'other storage' - Help needed

Discussion in 'macOS' started by jamierorison, Aug 10, 2013.

  1. jamierorison macrumors newbie

    Joined:
    May 8, 2013
    #1
    Hey

    I have tried everything under the sun, searched every help thread on google and am still lost, I hope you ladies and gents can help me out.

    I seem to be having problems with my hard drive randomly eating my available space but not from specific applications or programs or anything that I actually have stored on my mac. (running 2009 macbook pro and running latest OS X version of Lion).

    I'll give you an example and will post screenshots, so my example will be this:

    I recently have been using photoshop to complete work, I might have say... 3GB of space available on my HDD, whilst happily running photoshop and playing around with it (not saving files, simply just using it) I get the message 'your disk space is almost full', then when I look I have almost close to and sometimes exactly zero bites available. Now when I close the app, I regain maybe 500MB of that, but the rest is simply gone, it no longer exists on my mac.

    The same problem occurs when I use skype to video call my friends, or my lady friend. Sometimes we video call for four-five hours on a night, and during that the 'you have no space left on the HDD' message appears.

    I simply do not know where I am going wrong. Now, if it helps I will explain a problem I had a while ago but overcame with regards to a login loop... my original admin account one day decided to never let me log in again... which was annoying but I reinstalled lion and created a new, second admin account with all privileges and moved my files over - I thought perhaps there may have been data on that but looking on programmes such as omnisweeper and Jdisk report it doesn't show anything. in fact both programmes come back showing 40GB - which I guess must be the actual files and data stored on both of those accounts - but the 'other' section under storage shows 120+GB of stuff which I simply do not know how to locate and dispose of.

    I don't use time machine but have found out how to and have already disabled the backup screenshots. made zero impact as it wasn't activated anyway.

    any help is appreciated. I will post screenshots below. thanks and I'll stick around in case there's somebody out there much, much smarter than me (doesn't take much... ha)
     

    Attached Files:

  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    If you're wondering what "Other" category in the storage tab is about, this may help explain: For space issues not explained by the above, there are a few things you can try, some of which may or may not apply: Here are a few resolutions found by others with the same question:
     
  3. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #3
    From another reply I recently wrote:
    Copy and paste the following command-line into a Terminal window:
    Code:
    sudo du -Phxcd 1 /
    
    See the post for details, such as entering an admin password:
    http://forums.macrumors.com/showpost.php?p=17704970

    You may want to read the rest of that thread for other commands, and the context in which to use them.
     
  4. jamierorison thread starter macrumors newbie

    Joined:
    May 8, 2013
    #4
    Okay, thanks for your replies... but nothing has worked and I now have more issues... sigh.

    So I tried the pointers on the first reply which included checking various programmes I had already done, so I tried reindexing it and (see attatchment 1) this happened.

    then I tried the second response here in terminal by typing that request. Nothing happened, by nothing, I mean it shows (see attatchment 2) this.

    and then just for the hell of it I checked the storage tab again, and now this... I mean... jesus, the other space is creeping up. I haven't even done anything except run safari... what else can I try? nothing is working.

    (attatchment 3)
     

    Attached Files:

  5. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #5
    First, you didn't use the exact command-line I posted. Please do.

    Then copy and paste the output text into a reply. A picture of text isn't nearly as useful as the actual text. See the post previously linked to on how to use CODE tags for posting text.

    Second, I can't tell for sure, but I suspect the command hadn't completed when you made your screenshot. I see no prompt indicating that it completed. Also, there should be directories in / that are scanned after /home, but none of those are listed, so that's more evidence the command hasn't completed.

    One reason I included the -c option is because it calculates and prints a grand total when it completes. If you don't see a line that says "total", with a number that looks like a grand total, then the command hasn't completed. You need to wait for it to complete.

    If there really is 150+ GB of files, then the 'du' command will almost certainly take quite some time to complete. Since neither no one knows where any such files are located, you need to wait for it to complete, because no one knows where it can be expected to take a long time.


    If you're using other programs (such as the ones suggested by GGJstudios) to try to tell you where the space is going, you need to provide specific names of the programs you actually used.

    If they all say that 150+ GB of space is being used, then consider taking a screen shot of that program's display and posting it.
     

Share This Page