At wit's end with ATV 3 and Airplay failure

Discussion in 'Apple TV and Home Theater' started by puma1552, Feb 15, 2014.

  1. puma1552 macrumors 601

    Joined:
    Nov 20, 2008
    #1
    I have an ATV 3, and a retina iPad mini. I rented a movie from iTunes on my iPad, and then wanted to Airplay it on my Apple TV. Simple, right?

    No. Spent the last two hours unsuccessfully getting it to work, and now Saturday night is down the toilet and I'm going to be stuck watching the movie on the iPad.

    Home sharing is on on the ATV and the iPad, and even my laptop. The Apple ID on the ATV, the iPad, and even my laptop are the same. Airplay is on as well.

    When I start to play the movie on the iPad in the default Apple video app where iTunes rentals go, then press the little Airplay icon and send it to the Apple TV, the iPad tells me the movie is now on the Apple TV. However, it just flat out doesn't show up on Apple TV. When I do select the Airplay icon on the iPad, I get a little box in the lower left hand corner on my TV that says Now Playing: movie XXX and indicates that the movie is playing. Well, it is not. That little pop up disappears after a moment and then nothing happens, I'm just sitting at the regular old ATV home screen.

    I've already done a factory reset of the ATV and the wifi is working fine. Software is the most recent update. It just does absolutely nothing when I select to Airplay from my iPad.

    What's the deal here?
     
  2. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #2
    Router/access point having trouble streaming media?
    PS I personally would connect aTV to the network via a wire.
     
  3. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #3
    Either that, or a faulty ATV unit....seems like you've covered everything....the only other option is to get hold of a micro USB adaptor and do a complete reset and restore with the ATV connected to a Mac.
     
  4. sliceoftoast macrumors 6502

    sliceoftoast

    Joined:
    Mar 3, 2012
    Location:
    In a Toaster
    #4
    My ATV3 has kicked the bucket, it will no longer get a DHCP, from LAN and will not even acknowledge the wireless network in the house.
     
  5. waw74 macrumors 68030

    Joined:
    May 27, 2008
    #5
    there was a bug with some aTV3 where the wireless would stop working, apple will replace it.
    more details here
     
  6. puma1552 thread starter macrumors 601

    Joined:
    Nov 20, 2008
    #6
    Well I got it to work finally.

    Turns out I forgot to turn on mirroring from control center...I would've assumed when I pressed the airplay icon from the video app it would've done that anyway...seems very Microsoftish that it wouldn't turn on the mirroring anyway. I don't remember having to do that last time though.

    That said, it wasn't that simple, I still had to mess with it a bit before it worked...mirroring the iPad home screen worked fine but it took a few times toggling it on and off before the video would show on the TV. Not sure what happened, I'll have to play with it a bit more.

    Thanks guys.
     
  7. Cinephi1e macrumors regular

    Joined:
    Jul 19, 2012
    Location:
    Northwest Ohio
    #7
    What I don't understand is why would you want to airplay a rented iTunes movie when you can play it directly on the Apple TV. When I rent a movie I do it on my Mac or iPad as it is easier to input the info, but then it immediately pops up on the Apple TV in the rented section. I then just play it.
     
  8. Piertown macrumors member

    Joined:
    Sep 18, 2013
    Location:
    London
    #8
    That's exactly what I do
     
  9. PM-Performance macrumors 6502

    Joined:
    Feb 12, 2012
    #9

    This!
    Why complicate things and. It use the atv to its extent?
     
  10. gatearray macrumors 65816

    Joined:
    Apr 24, 2010
    #10
    Agreed! It seems very Microsoftish to do it any other way. :)
     

Share This Page