At Wit's End... :-(

Discussion in 'MacBook Pro' started by SpaceAce57201, Jan 16, 2012.

  1. SpaceAce57201 macrumors newbie

    Joined:
    Jan 16, 2012
    #1
    Let me first start by thanking anyone who may be able to assist...

    My mid-2009 MBP recently started freezing up while it was sleeping which required me to hold the power button down to shut it off for a reboot. This happened 3 times in as many weeks.

    The last time it did this, it did not come back :-(

    I have went into the recovery utility and ran disk repair on the HD - there were no issues detected (that is a good thing) but the computer still would not boot.

    I then decided to bite the bullet and do a fresh install of Lion (using the USB bootable flash drive that I had made). I booted the computer into the recovery utility, wiped the HD (without issue) and installed Lion (without issue - or so I thought). While Lion was installing, it said it would automatically reboot the computer when finished but it did not - I did this manually once the progress indicator had disappeared but no luck - the computer booted to the recovery utility (on the flash drive). I removed the flash drive and then got the "no file system" flashing folder icon with a question mark in it.

    So... I thought it must be the HD - today, I just received a new WD Scorpio Black 320GB HD and installed - the disk utility sees it fine, I formatted it, installed Lion (again) but it still will not boot to it :-(

    At this point, I thought it must be the SATA cable so I removed the HD, connected it to USB (via an adapter I have) - the computer does not find it...

    Is there something I am missing or do I now just have a $1200.00 aluminum paper weight???

    I am a PC guy and this MBP was my first forray into Mac-dom and am getting a little dis-heartened as I can usually figure this stuff out but this one has me completely stumped...

    Thoughts?

    Thanks so much in advance for your time!
     
  2. kfergiez macrumors 6502

    kfergiez

    Joined:
    Jul 5, 2010
    #2
    Whenever your computer goes to sleep, it holds the information in local memory, not on your HD. It seems that your HD is fine, the problem may lie in the logic board itself or in the RAM. Have you upgraded your RAM?
     
  3. chillfrilla macrumors member

    Joined:
    Dec 30, 2011
  4. SpaceAce57201 thread starter macrumors newbie

    Joined:
    Jan 16, 2012
    #4
    RAM was upgraded probably 18 months ago. Truly, I don't think that is the issue as when I attempt to boot the Mac from the new Lion install done on the new HD, the drive does not show at all...
     
  5. SpaceAce57201 thread starter macrumors newbie

    Joined:
    Jan 16, 2012
    #5
    The only thing I can think of is that somehow the bootable USB flash drive I created for re-installing Lion "clean" is not working properly... I will try to install Snow Leopard from the CD and see how that goes - will post back later today.
     
  6. SpaceAce57201 thread starter macrumors newbie

    Joined:
    Jan 16, 2012
    #6
    Hopefully the last update/comment on this...

    So I tried to install Snow Leopard on both the internal (new) WD drive connected via the internal SATA cable and the original Hitachi drive connected via USB adapter - no luck on either - the installation ran about 1/3 of the way through and came back with an error that it could not install the support files.

    The only thing left to try was to put the original Mac memory back in - THIS WORKED!

    I had read somewhere that Apple computers are very "picky" in regards to memory but I had purchased the same spec memory (just larger modules) from Crucial (reputable memory dealer as for PC I have always bought my memory from them several times in the past without issue) and the memory had been working great in the laptop for the last 18 months (approximation)... Apparently, it is no longer working "fine".

    Time to crack open the champagne (and call Crucial)! It's alive!! :)
     
  7. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #7
    I've had RAM go wonky on me like that in my machine, no amount of testing RAM found anything, but I would keep on getting kernel panics. Eventually bought RAM to replace what I've got, and lo and behold, it worked.
     

Share This Page