ATI 6870 - iTunes Kernel Panic - 10.7.4 - Help?

Discussion in 'Mac Pro' started by Dr. Cheesesteak, Jul 20, 2012.

  1. Dr. Cheesesteak, Jul 20, 2012
    Last edited: Jul 20, 2012

    Dr. Cheesesteak macrumors member

    Jan 27, 2005
    I'm having problems with iTunes causing KP's after installing this ATI card a few weeks ago. It seems intermittent and every time I think I've found a fix it works for about a week and then happens again.

    I've been searching here, netkas, and google and can't seem to find a solution that actually works - but I'm feeling overwhelmed at this point trying to find the right solution. I get the feeling this isn't something most people have problems with as I can't find threads about it specifically - just mentions here and there. Any help would be awesome.

    Here is where I'm at:

    Mac Pro - 4,1 - 2.66 Quad Core
    ATI Radeon Sapphire 6870 1GB

    Card booted fine in OS X/Windows out of the box with the expected DVD/Steam/Boot Screen issues.

    Flashed BIOS using Win7 and a few tools I don't remember the name of - things I found on netkas forums.

    Back in OS X - almost everything seems to work fine. Boot screen is there, Steam works, DVD player works. Performance is great. But...

    Launching iTunes causes a KP immediately. Found a forum post about something called UVD and a patch on netkas to add to the ATIRadeonX3000.kext that is supposed to disable the source of the problem. Then the system works fine for a few days, and suddenly launching iTunes crashes again. My system is almost always on and only the displays sleep, so I don't know how that kext could be getting reset but that almost seems like it is the problem. Repatching seems to get me a few days and then I'm back to KPs.

    The KPs usually say something about power management kext or the ati kext - I'm not at the machine right now but can post one when I get home if that would help.

    I've tried reflashing the card but it tells me the BIOS is the same and won't flash it. OS X does register the new BIOS.

    Any thoughts? I'm *not* supposed to be using the ATY_Init if I flashed, right? Because that's the only thing I think I haven't tried so far.



    Flashed back to the original BIOS. Flash seemed to work fine. No boot screen.

    Installed the ATY_Init kext from the 6870 Package. Fixed the DVD/Steam crashes - but iTunes is still crashing? Pulled a fistful of hair out. Screamed into a pillow.

    I also have kept my GT120 installed so I could have dual monitors until I could order an adapter. Maybe I'll try pulling that next... could that be part of it?
  2. Dr. Cheesesteak, Jul 21, 2012
    Last edited: Jul 21, 2012

    Dr. Cheesesteak thread starter macrumors member

    Jan 27, 2005
    Nevermind the last edit. Ram is fine. Crashes happen even with the stock ram. Here is the last panic:

    Sat Jul 21 11:47:20 2012
    Machine-check capabilities (cpu 4) 0x0000000000001c09:
     family: 6 model: 26 stepping: 5 microcode: 17
     Intel(R) Xeon(R) CPU           W3520  @ 2.67GHz
     9 error-reporting banks
     threshold-based error status present
     extended corrected memory error handling present
    Machine-check status 0x0000000000000004:
     machine-check in progress
    MCA error-reporting registers:
     IA32_MC0_STATUS(0x401): 0x0000000000000800 invalid
     IA32_MC1_STATUS(0x405): 0x0000000000000800 invalid
     IA32_MC2_STATUS(0x409): 0x0000000000000000 invalid
     IA32_MC3_STATUS(0x40d): 0x0000000000000000 invalid
     IA32_MC4_STATUS(0x411): 0x0000000000000000 invalid
     IA32_MC5_STATUS(0x415): 0x0000000000000000 invalid
     IA32_MC6_STATUS(0x419): 0x0000000000000000 invalid
     IA32_MC7_STATUS(0x41d): 0x0000000000000000 invalid
     Package 0 logged:
     IA32_MC8_STATUS(0x421): 0x0000000000000000 invalid
    panic(cpu 5 caller 0xffffff80002c4d65): "Machine Check at 0xffffff7f822dfd7a, registers:\n" "CR0: 0x000000008001003b, CR2: 0x000000010cb3f868, CR3: 0x0000000000100000, CR4: 0x0000000000000660\n" "RAX: 0x0000000000000020, RBX: 0x0000000000000000, RCX: 0x0000000000000001, RDX: 0x0000000000000000\n" "RSP: 0xffffff81d1243d80, RBP: 0xffffff81d1243db0, RSI: 0x0000000000000006, RDI: 0xffffff8020aa2000\n" "R8:  0xffffff8020905800, R9:  0x00000000ffffffff, R10: 0x0000000000000000, R11: 0xffffff80002da8d0\n" "R12: 0x00000000000007b0, R13: 0xffffff80207c29c0, R14: 0xffffff8020905800, R15: 0x0000000000000006\n" "RFL: 0x0000000000000046, RIP: 0xffffff7f822dfd7a, CS:  0x0000000000000008, SS:  0x0000000000000010\n" "Error code: 0x0000000000000000\n"@/SourceCache/xnu/xnu-1699.26.8/osfmk/i386/trap_native.c:278
    Backtrace (CPU 5), Frame : Return Address
    0xffffff81c70e2ec0 : 0xffffff8000220792 
    0xffffff81c70e2f40 : 0xffffff80002c4d65 
    0xffffff81c70e30a0 : 0xffffff80002daa9f 
    0xffffff81d1243db0 : 0xffffff7f822d72a5 
    0xffffff81d1243e80 : 0xffffff7f822d8d9c 
    0xffffff81d1243f30 : 0xffffff80002c63b2 
    0xffffff81d1243f50 : 0xffffff800022d375 
    0xffffff81d1243f90 : 0xffffff800022ccdb 
    0xffffff81d1243fb0 : 0xffffff8000820057 
          Kernel Extensions in backtrace:
    BSD process name corresponding to current thread: kernel_task
    Mac OS version:
    Kernel version:
    Darwin Kernel Version 11.4.0: Mon Apr  9 19:32:15 PDT 2012; root:xnu-1699.26.8~1/RELEASE_X86_64
    Kernel UUID: A8ED611D-FB0F-3729-8392-E7A32C5E7D74
    System model name: MacPro4,1 (Mac-F221BEC8)
    System uptime in nanoseconds: 1036974483909
    last loaded kext at 23609296508:	85.2 (addr 0xffffff7f8134e000, size 16384)
    last unloaded kext at 123940293106:	2.1.3b1 (addr 0xffffff7f81354000, size 110592)
    loaded kexts:
    com.bresink.driver.BRESINKx86Monitoring	9.0	8.2	8.2
    jp.plentycom.driver.SteerMouse	4.1.4	85.2	1.9.5d0	3.0	70.12	122	3.5.9	1.0.26	7.1.8	2.2.0f3	2.2.0f3	1.59	1.0.2d2	100.12.42	7.1.8	3.10.1	1.0.0d1	4.0.5f11	7.0.0	1.2.2	5.0.0d0	7.1.8	1.5.8	4.0.5f11	3.2.0	1.0.0d1	1.0.0d1	33	404	4.8.9	2.0.3	2.0.3	4.5.0	530.4.20	2.2.0b2	2.3.0	4.5.8	4.4.5	1.5.0	1.5	1.6	1.5	1.8	1.5	1.5	193.0.0	3.2.30	1.3	193.0.0	85.2	85.2	85.2	85.2	85.2	85.2	85.2	1.0	231.4	2.2.0f3	1.0.10d0	7.1.8	7.1.8	80.0.2	10.0.5	2.2.4	1.8.6fc17	1.3	2.2.0f3	2.2.0f3	3.0.16	3.0.16	3.1.3d8	5.0.0d0	1.0.10d0	5.1.0d17	7.1.8	7.1.8	2.3.2	2.3.2	4.0.5f11	4.0.5f11	4.0.5f11	4.4.5	4.5.3	4.5.8	3.2.0	1.6	1.7	1.7	4.4.5	3.2.0	420.3	4.5.8	2.1	2.0.8	4.5.8	1.5.0	1.7.1	1.1	177.5	1.0.0d1	7	331.6	1.7.1	28.18	1.5	2.6.8	1.4

Share This Page