ATI DRIVERS 2011 iMAC!!!

Discussion in 'iMac' started by swarleystinson, May 18, 2011.

  1. swarleystinson macrumors member

    swarleystinson

    Joined:
    Aug 12, 2010
    Location:
    Hoboken, NJ
    #1
    Guys, anyone no any way to install mobility drivers in bootcamp on the iMac?
    On the mid-2010 model it was possible to install mobility drivers which helped performance significantly in windows 7.

    I keep getting errors when I try and install anything other than the bootcamp drivers. They're presently the same as the "Mac > Boot Camp" drivers found on AMD's website, but they do not seem to include catalyst control center.

    The fixes that are suggested on other forums for the game I'm interested in playing (Witcher 2) do not apply to boot camp drivers.

    Has anyone had success in installing CCC 11.5 drivers?
     
  2. MythicFrost macrumors 68040

    MythicFrost

    Joined:
    Mar 11, 2009
    Location:
    Australia
    #2
  3. imacken macrumors 65816

    Joined:
    Feb 28, 2010
    #3
    They don't work for me. I just get an ATI error saying '...Mobility Cannot be downloaded due to incompatible hardware..... Your computer does not contain a proper graghics card'!!
    Anyone else got it working?
     
  4. trackbikes macrumors regular

    Joined:
    Mar 29, 2011
    #4
    I had it working fine under bootcamp....
     
  5. imacken macrumors 65816

    Joined:
    Feb 28, 2010
    #5
    and you're on a 2011 Mac with a HD 6970M 1Gb?
     
  6. trackbikes macrumors regular

    Joined:
    Mar 29, 2011
    #6

    2011 21.5 imac with 6770

    I would check but it refused to power on today.
     
  7. alexey2k macrumors newbie

    Joined:
    Apr 5, 2011
    #7
    I just installed the bootcamp drivers from the DVD and it's running just fine.
     
  8. imacken macrumors 65816

    Joined:
    Feb 28, 2010
    #8
    So, are you saying that The Witcher 2 runs fine for you on the Bootcamp drivers on your 27" @ 2560x1440 HD 6970M?
     
  9. swarleystinson thread starter macrumors member

    swarleystinson

    Joined:
    Aug 12, 2010
    Location:
    Hoboken, NJ
    #9
    It seems like iMacken and I are the only 2 on the same wavelength here.
    Unless you have specific recommendations for the 2011 iMac 27" with Radeon HD 6970m...

    As I said, I had no problem installing mobility drivers on my mid-2010 iMac. But the same process is not working on this particular iMac. I'm wondering if there is something unique to Mac architecture that is allowing for bootcamp drivers only. If so, then hotfixes and updates I'm assuming will be similarly as slow to update as they are for mac osx.
     
  10. swarleystinson thread starter macrumors member

    swarleystinson

    Joined:
    Aug 12, 2010
    Location:
    Hoboken, NJ
    #10
    Mythic Frost, did this pertain to 6970m iMac? If so, can you be more specific? I am receiving the same error as imacken when I attempt to uninstall and reinstall the latest mobility drivers.
     
  11. Georgio macrumors 6502

    Georgio

    Joined:
    Apr 30, 2008
    Location:
    Essex, UK
    #11
    I had that on my iMac, I tried the individual downloads as well and never got them working.
    I had problems with the GPU not ramping up in OSX so returned the machine.

     
  12. MythicFrost macrumors 68040

    MythicFrost

    Joined:
    Mar 11, 2009
    Location:
    Australia
    #12
    I'm having the same problem. I just bought a 2011 iMac and I'm unable to get the mobility graphics installed. Did you figure it out?
    Sorry, I didn't notice this reply. And no, it was for an 09 iMac with the 4850M.
     
  13. Georgio macrumors 6502

    Georgio

    Joined:
    Apr 30, 2008
    Location:
    Essex, UK
    #13
    I never managed to get anything other than the stock bootcamp drivers to install either.
    Really retarded that Apple feel they have to 'nanny' us; if I want to install the latest drivers and possibly 'break' my Win7 then that should be my choice, not theirs. :mad:
     
  14. MythicFrost macrumors 68040

    MythicFrost

    Joined:
    Mar 11, 2009
    Location:
    Australia
    #14
    Argh, that sucks. Thanks for letting me know though.
     
  15. Toddi macrumors newbie

    Joined:
    Aug 23, 2010
    Location:
    Germany
    #15
    Please try this, and after you installed that "old" Driver, you can upgrade with the newest mobile Catalyst from AMD.

     
  16. Georgio macrumors 6502

    Georgio

    Joined:
    Apr 30, 2008
    Location:
    Essex, UK
    #16
    Excellent work, I'll try that tonight thanks :D

     
  17. OliverOSX93 macrumors regular

    Joined:
    Jun 26, 2010
    Location:
    Accrington
  18. imacken macrumors 65816

    Joined:
    Feb 28, 2010
    #18
    I tried this, and although the modded drivers installed OK, trying an update from AMD site just gave the usual '....cannot be downloaded... Your computer does not contain a proper graphics adapter'.
     
  19. Toddi macrumors newbie

    Joined:
    Aug 23, 2010
    Location:
    Germany
    #19
    Strange...

    What kind of OS you are using with Bootcamp? If you use Win7 64-Bit please try this Driver:

    http://support.amd.com/us/kbarticles/Pages/Catalyst118DriverPreview.aspx

    But i think it's better to play the Witcher2 with 1080P instead of 2560*1440. I tried it by myself, and with 2560*1440 and Med. Details i had ~20 FPS, unplayable. With 1080P you will have ~40 FPS and it still looks good.
     
  20. imacken macrumors 65816

    Joined:
    Feb 28, 2010
    #20
    Thanks. Yes, these installed OK, but I wasn't having any problem installing any drivers. It's on the main AMD site where there is a problem.
    On the Witcher 2, on high settings, I get 25-40 @2560, and 40-55 @1920.
     

Share This Page